summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64212d8d2e5..323c64f140b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = courier-mta
pkgdesc = IMAP(s)/POP3(s) and SMTP Server with ML-manager, webmail and webconfig
- pkgver = 1.1.5
- pkgrel = 2
+ pkgver = 1.1.10
+ pkgrel = 1
url = http://courier-mta.org
install = courier-mta.install
arch = i686
@@ -15,7 +15,7 @@ pkgbase = courier-mta
depends = courier-unicode>=2.1
depends = gcc-libs
depends = gdbm
- depends = pcre
+ depends = pcre2
depends = mime-types
depends = ca-certificates
depends = libidn
@@ -42,7 +42,7 @@ pkgbase = courier-mta
backup = etc/courier/esmtpd.cnf
backup = etc/courier/pop3d.cnf
backup = etc/courier/esmtpauthclient
- source = http://downloads.sourceforge.net/project/courier/courier/1.1.5/courier-1.1.5.tar.bz2
+ source = http://downloads.sourceforge.net/project/courier/courier/1.1.10/courier-1.1.10.tar.bz2
source = courier-imapd.service
source = courier-imapd-ssl.service
source = courier-pop3d.service
@@ -56,7 +56,7 @@ pkgbase = courier-mta
source = webmaild.service
source = courier-courierfilter.service
source = courier-mta.conf
- sha1sums = e79c4529138ccdbe4c58530f4d13ccd8597faa5d
+ sha1sums = d98159eea54aaeec804b8a8672918b852c3198e1
sha1sums = 68012617edb5d82a99245bd7a7e319d88580e110
sha1sums = 8400fc2538aebbb68933eac3c4d82b4303c61315
sha1sums = c52f436744307d3777a852cfaa85b4ff6345f4a4
diff --git a/PKGBUILD b/PKGBUILD
index e51f12e5492..a60b2428d1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,13 +10,13 @@
# If upgrading, you must read the guidance at http://www.courier-mta.org/maildirmake.html on "Converting pre-unicode format maildirs"
pkgname=courier-mta
-pkgver=1.1.5
-pkgrel=2
+pkgver=1.1.10
+pkgrel=1
pkgdesc="IMAP(s)/POP3(s) and SMTP Server with ML-manager, webmail and webconfig"
arch=(i686 x86_64)
license=('GPL2')
url="http://courier-mta.org"
-depends=('courier-authlib>=0.71' 'courier-unicode>=2.1' 'gcc-libs' 'gdbm' 'pcre' 'mime-types' 'ca-certificates' 'libidn' 'wget')
+depends=('courier-authlib>=0.71' 'courier-unicode>=2.1' 'gcc-libs' 'gdbm' 'pcre2' 'mime-types' 'ca-certificates' 'libidn' 'wget')
optdepends=('libldap')
makedepends=('pam' 'expect' 'gnupg' 'libldap')
provides=('smtp-server' 'smtp-forwarder' 'imap-server' 'pop3-server' 'courier-imap' 'courier-maildrop')
@@ -39,7 +39,7 @@ source=(http://downloads.sourceforge.net/project/courier/courier/${pkgver}/couri
webmaild.service
courier-courierfilter.service
courier-mta.conf)
-sha1sums=('e79c4529138ccdbe4c58530f4d13ccd8597faa5d'
+sha1sums=('d98159eea54aaeec804b8a8672918b852c3198e1'
'68012617edb5d82a99245bd7a7e319d88580e110'
'8400fc2538aebbb68933eac3c4d82b4303c61315'
'c52f436744307d3777a852cfaa85b4ff6345f4a4'
@@ -128,7 +128,4 @@ package() {
# because Arch bin and sbin are same location the binary would be overwritten by the link
install -m 755 "${srcdir}/courier-${pkgver}/courier/imapd" "${pkgdir}/usr/lib/courier/courierimapd"
sed -i 's/\/usr\/bin\/imapd/\/usr\/lib\/courier\/courierimapd/' "${pkgdir}/usr/share/imapd" "${pkgdir}/usr/share/imapd-ssl"
-
- # patch just for ths version - in anticipation of it being added to official courier release shortly.
- sed -i '76 a restart)\n\t/usr/bin/courierlogger -pid=$SSLPIDFILE -restart\n\t;;' "${pkgdir}/usr/share/imapd-ssl"
}