summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD28
-rw-r--r--courier-mta.install2
3 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 044911ec3514..9c10f25f5026 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = courier-mta
pkgdesc = IMAP(s)/POP3(s) and SMTP Server with ML-manager, webmail and webconfig
pkgver = 0.77.0
- pkgrel = 2
+ pkgrel = 3
url = http://courier-mta.org
install = courier-mta.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index c3c5c50c2614..8971e1ea8d68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=courier-mta
pkgver=0.77.0
-pkgrel=2
+pkgrel=3
pkgdesc="IMAP(s)/POP3(s) and SMTP Server with ML-manager, webmail and webconfig"
arch=(i686 x86_64)
license=('GPL2')
@@ -50,7 +50,7 @@ sha1sums=('6a79c331e2b2ac771455d4333947bfbc7d381b57'
'b5aa73e428d568b20c8d59ef029e1740e8f9ef34')
build() {
- cd ${srcdir}/courier-${pkgver}
+ cd "${srcdir}/courier-${pkgver}"
LDFLAGS+=",-L /usr/lib/courier-authlib -lcourierauth"
@@ -75,21 +75,21 @@ build() {
}
package() {
- cd ${srcdir}/courier-${pkgver}
+ cd "${srcdir}/courier-${pkgver}"
- make DESTDIR=${pkgdir} install
+ make "DESTDIR=${pkgdir} install"
# install the perftest-script for testings
- install -Dm 755 courier/perftest1 ${pkgdir}/usr/lib/courier/perftest1
+ install -Dm 755 courier/perftest1 "${pkgdir}/usr/lib/courier/perftest1"
# install sysconftool to perform the install-configure step after installation
- install -Dm 755 sysconftool ${pkgdir}/usr/lib/courier/sysconftool
+ install -Dm 755 sysconftool "${pkgdir}/usr/lib/courier/sysconftool"
# install pam files according to the layout used in Arch linux
- for pamfile in ${pkgdir}/etc/courier/*.authpam; do
- sed -i 's|/lib/security/pam_pwdb\.so|pam_unix.so|' ${pamfile}
- install -Dm 644 ${pamfile} ${pkgdir}/etc/pam.d/$(basename ${pamfile} .authpam | sed "s/d$//")
- rm -f ${pamfile}
+ for _pamfile in "${pkgdir}/etc/courier/*.authpam"; do
+ sed -i 's|/lib/security/pam_pwdb\.so|pam_unix.so|' "${_pamfile}"
+ install -Dm 644 "${_pamfile}" "${pkgdir}"/etc/pam.d/$(basename "${_pamfile}" .authpam | sed "s/d$//")
+ rm -f "${_pamfile}"
done
# Install systemd service files
@@ -108,7 +108,7 @@ package() {
install -Dm 644 "${srcdir}/courier-mkdhparams.timer" "${pkgdir}/usr/lib/systemd/system/courier-mkdhparams.timer"
# pacman gives an error for /var/run file conflict. Circumvent this by removing the directory
- rm -rf ${pkgdir}/var/run
+ rm -rf "${pkgdir}/var/run"
# Install systemd configuration file which will set up empty /run/courier directory (and clean up after uninstall)
@@ -116,9 +116,9 @@ package() {
# create password file for webadmin -> standard archwebadmin
- echo archwebadmin > ${pkgdir}/etc/courier/webadmin/password
- chown courier:courier ${pkgdir}/etc/courier/webadmin/password
- chmod 400 ${pkgdir}/etc/courier/webadmin/password
+ echo archwebadmin > "${pkgdir}/etc/courier/webadmin/password"
+ chown courier:courier "${pkgdir}/etc/courier/webadmin/password"
+ chmod 400 "${pkgdir}/etc/courier/webadmin/password"
# install the imapd binary as /usr/lib/courier/courierimapd and modify usr/share scripts.
# courier-mta by default installs usr/bin/imapd as the binary, usr/share/imapd as script file and usr/sbin/imapd as link to /usr/share/imapd
diff --git a/courier-mta.install b/courier-mta.install
index a7783d521840..65ed42661c9f 100644
--- a/courier-mta.install
+++ b/courier-mta.install
@@ -14,7 +14,7 @@ post_install() {
pre_upgrade() {
# the file courier-imapd.conf is renamed to courier-mta.conf for version 0.77.0-2
- [ "$1" = "0.77.0-2" ] && rm -f /usr/lib/tmpfiles.d/courier-imapd.conf
+ [ -f /usr/lib/tmpfiles.d/courier-imapd.conf ] && rm -f /usr/lib/tmpfiles.d/courier-imapd.conf
}
post_upgrade() {