summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
-rw-r--r--cover-thumbnailer.install10
3 files changed, 22 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36186619f120..c7fc76ece2d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = cover-thumbnailer
- pkgdesc = A Python script which displays music album covers in nautilus, preview of pictures which are in a folder and more.
- pkgver = 0.8.3
- pkgrel = 6
- url = https://launchpad.net/cover-thumbnailer
+ pkgdesc = A Python script which generates folder thumbnails for various file browser on Linux. It displays music album covers, preview of pictures which are in a folder and more.
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = https://github.com/flozz/cover-thumbnailer
install = cover-thumbnailer.install
arch = i686
arch = x86_64
license = GPL3
- depends = python2-pillow
- depends = python2-gconf
- provides = cover-thumbnailer
- source = https://launchpad.net/cover-thumbnailer/v0.8/v0.8.3/+download/cover-thumbnailer_0.8.3_src.tar.gz
- sha256sums = c0d5213743cb251428b9998d7838d6d6e64bb4bb9ccd3a21ffebb3fc21b688c4
+ depends = python-pillow
+ conflicts = cover-thumbnailer-git
+ source = cover-thumbnailer-0.10.0.tar.gz::https://github.com/flozz/cover-thumbnailer/archive/v0.10.0.tar.gz
+ sha256sums = dc54c9308e2b6b7d4c182b2bacfa7b46bb4bedc486565f5285e0e2a1772f52e4
pkgname = cover-thumbnailer
diff --git a/PKGBUILD b/PKGBUILD
index c8af34b66e1a..02071a46303e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,27 @@
#
# Contributor: Moritz Lüdecke <ritze at skweez dot net>
# Contributor: boenki <boenki at gmx dot de>
-
+#
pkgname="cover-thumbnailer"
-pkgver="0.8.3"
-pkgrel="6"
-pkgdesc="A Python script which displays music album covers in nautilus, preview of pictures which are in a folder and more."
+pkgver="0.10.0"
+pkgrel="1"
+pkgdesc="A Python script which generates folder thumbnails for various file browser on Linux. It displays music album covers, preview of pictures which are in a folder and more."
arch=('i686' 'x86_64')
-url="https://launchpad.net/cover-thumbnailer"
+url="https://github.com/flozz/cover-thumbnailer"
license=('GPL3')
-depends=('python2-pillow' 'python2-gconf')
-provides=("${pkgname}")
-source=("https://launchpad.net/${pkgname}/v0.8/v${pkgver}/+download/${pkgname}_${pkgver}_src.tar.gz")
-sha256sums=('c0d5213743cb251428b9998d7838d6d6e64bb4bb9ccd3a21ffebb3fc21b688c4')
+depends=('python-pillow')
+conflicts=("${pkgname}"-git)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('dc54c9308e2b6b7d4c182b2bacfa7b46bb4bedc486565f5285e0e2a1772f52e4')
install="${pkgname}.install"
-build() {
- cd "${srcdir}/${pkgname}_${pkgver}_src"
-
- ### Python2 Fix ###
- sed -i "s|#!/usr/bin/python|#!/usr/bin/python2|g" ${pkgname}{,-gui}.py
-
- ### Python2-pillow (PIL) Fix ###
- sed -i "/import Image/i\from PIL import Image" ${pkgname}.py
- sed -i "s|import Image, urllib|import urllib|g" ${pkgname}.py
- sed -i "s|!=|is not|g" ${pkgname}.py
-
- ### Thumbnailers cache Fix (Gnome 3.12) ###
- sed -i "s|.thumbnails|.cache/thumbnails|g" ${pkgname}-gui.py
-}
-
package() {
- cd "${srcdir}/${pkgname}_${pkgver}_src"
+ cd "${pkgname}-${pkgver}"
+
./install.sh -p ${pkgdir}
+
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-# vim:set ts=4 sw=4 et syn=sh ft=sh:
+# vim: set ts=4 sw=4 et syn=sh ft=sh:
diff --git a/cover-thumbnailer.install b/cover-thumbnailer.install
index eea40442e347..197f3d0dbe87 100644
--- a/cover-thumbnailer.install
+++ b/cover-thumbnailer.install
@@ -1,19 +1,9 @@
# cover-thumbnailer.install
post_install() {
- update-desktop-database -q
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
echo ""
echo " Do not forget to delete the cache of thumbnails:"
echo " rm rf ~/.thumbnails"
echo " rm rf ~/.cache/thumbnails"
echo ""
}
-
-post_upgrade() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_remove() {
- post_install $1
-}