summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
-rw-r--r--makedev_glibc_fix.patch20
-rw-r--r--series1
4 files changed, 45 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd25ac1cbd86..6c6fe58f5009 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,23 @@
pkgbase = cowdancer
pkgdesc = Copy-on-write wrapper for pbuilder
- pkgver = 0.86
+ pkgver = 0.87
pkgrel = 1
url = https://packages.debian.org/sid/cowdancer
arch = i686
arch = x86_64
license = GPL
+ makedepends = quilt
depends = pbuilder-ubuntu
depends = ncurses
depends = ncurses5-compat-libs
optdepends = qemu: if you want to use qemubuilder
optdepends = bash-completion: bash autocomplete support
- source = http://httpredir.debian.org/debian/pool/main/c/cowdancer/cowdancer_0.86.tar.xz
- sha256sums = 7a2bd85025bc585543e189aa5f48f4088d30c89885d9d9576295f9a844ee6bf7
+ source = http://httpredir.debian.org/debian/pool/main/c/cowdancer/cowdancer_0.87.tar.xz
+ source = series
+ source = makedev_glibc_fix.patch
+ sha256sums = d5696d80197e727363833c0e5c520867bd10e456d5b5856a35bfdbdffc533a9c
+ sha256sums = c7345323ff3cf9f3e7f7339319f06b14a001dd75fc7720ad4e58ae99db2a62ea
+ sha256sums = ef983677d8218b3301f194129d9b97f39abf9a4463aa5b6da7b4c376b5b20ed1
pkgname = cowdancer
diff --git a/PKGBUILD b/PKGBUILD
index f264052d48ab..64743484c8ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: JD Horelick <jdhore1@gmail.com>
# Contributor: Alad Wenter <alad@linuxbbq.org>
pkgname=cowdancer
-pkgver=0.86
+pkgver=0.87
pkgrel=1
pkgdesc="Copy-on-write wrapper for pbuilder"
arch=('i686' 'x86_64')
@@ -11,11 +11,24 @@ license=('GPL')
depends=('pbuilder-ubuntu'
'ncurses'
'ncurses5-compat-libs')
+makedepends=('quilt')
optdepends=('qemu: if you want to use qemubuilder'
'bash-completion: bash autocomplete support')
-source=(http://httpredir.debian.org/debian/pool/main/c/$pkgname/${pkgname}_${pkgver}.tar.xz)
-sha256sums=('7a2bd85025bc585543e189aa5f48f4088d30c89885d9d9576295f9a844ee6bf7')
+source=(http://httpredir.debian.org/debian/pool/main/c/$pkgname/${pkgname}_${pkgver}.tar.xz
+ series
+ makedev_glibc_fix.patch)
+sha256sums=('d5696d80197e727363833c0e5c520867bd10e456d5b5856a35bfdbdffc533a9c'
+ 'c7345323ff3cf9f3e7f7339319f06b14a001dd75fc7720ad4e58ae99db2a62ea'
+ 'ef983677d8218b3301f194129d9b97f39abf9a4463aa5b6da7b4c376b5b20ed1')
+
+prepare() {
+ mkdir ${pkgname}-${pkgver}/patches
+ cp series ${pkgname}-${pkgver}/patches/
+ cp makedev_glibc_fix.patch ${pkgname}-${pkgver}/patches/
+ cd ${pkgname}-${pkgver}
+ quilt push -a
+}
build() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/makedev_glibc_fix.patch b/makedev_glibc_fix.patch
new file mode 100644
index 000000000000..8e51b238fd6f
--- /dev/null
+++ b/makedev_glibc_fix.patch
@@ -0,0 +1,20 @@
+--- a/qemuarch.c
++++ b/qemuarch.c
+@@ -24,6 +24,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/stat.h>
+ #include <sys/wait.h>
+ #include <sys/socket.h>
+--- a/test_file.c
++++ b/test_file.c
+@@ -5,6 +5,7 @@
+ #include <unistd.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include "file.h"
+ #include "parameter.h"
+
diff --git a/series b/series
new file mode 100644
index 000000000000..9c18b8257c96
--- /dev/null
+++ b/series
@@ -0,0 +1 @@
+makedev_glibc_fix.patch