summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
-rw-r--r--cozy.install5
3 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c41a6017fbc9..eae42c31280c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Mar 14 19:36:20 UTC 2016
+# Tue Mar 15 18:40:44 UTC 2016
pkgbase = cozy
pkgdesc = A personal cloud you can hack, host and delete.
pkgver = 2.0
- pkgrel = 1
+ pkgrel = 2
url = https://cozy.io/
install = cozy.install
arch = any
@@ -15,6 +15,7 @@ pkgbase = cozy
depends = curl
depends = git
depends = imagemagick
+ depends = coffee-script
depends = openssl
depends = libxml2
depends = libxslt
diff --git a/PKGBUILD b/PKGBUILD
index 3e86f6755c23..29ae164d2264 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Brendan Abolivier <brendan@cozycloud.cc>
pkgname=cozy
pkgver=2.0
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="A personal cloud you can hack, host and delete."
arch=('any')
url="https://cozy.io/"
license=('GPL3')
groups=()
-depends=('ca-certificates' 'couchdb' 'supervisor' 'bash' 'curl' 'git' 'imagemagick'
+depends=('ca-certificates' 'couchdb' 'supervisor' 'bash' 'curl' 'git' 'imagemagick' 'coffee-script'
'openssl' 'libxml2' 'libxslt' 'python2' 'python2-setuptools' 'python2-virtualenv' 'sqlite'
'nodejs-lts-bin' 'pwgen' 'pngcrush' 'lsof' 'cozy-management')
makedepends=()
diff --git a/cozy.install b/cozy.install
index 7a0f556eef71..97d5fb515c80 100644
--- a/cozy.install
+++ b/cozy.install
@@ -35,9 +35,6 @@ post_install() {
exit 1
fi
- msg "Installing CoffeeScript"
- npm install -g coffee-script
-
msg 'Installing NPM dependencies...'
npm config set python /usr/bin/python2
[ ! -d /usr/local/lib/node_modules/cozy-controller ] && npm install -g cozy-controller
@@ -178,7 +175,7 @@ post_remove() {
[ -d /usr/share/cozy ] && rm -rf /usr/share/cozy
msg "Removing NPM dependencies"
[ -f /usr/bin/cozy-controller ] && npm remove -g cozy-controller
- [ -f /usr/bin/cozy-controller ] && npm remove -g cozy-monitor
+ [ -f /usr/bin/cozy-monitor ] && npm remove -g cozy-monitor
msg "Removing supervisor configuration"
test -e /etc/supervisor.d/cozy* && rm /etc/supervisor.d/cozy*
supervisorctl reload