summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19349d7a8e0a..ad9c30813bb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cpeditor
pkgdesc = The editor for competitive programming
- pkgver = 6.2.5
+ pkgver = 6.3.3
pkgrel = 1
url = https://github.com/cpeditor/cpeditor
arch = x86_64
@@ -8,10 +8,10 @@ pkgbase = cpeditor
makedepends = cmake
makedepends = git
makedepends = gcc
+ makedepends = python3
depends = qt5-base
conflicts = cpeditor-git
- source = https://github.com/cpeditor/cpeditor/releases/download/6.2.5/cpeditor-full-source-6.2.5.tar.gz
+ source = https://github.com/cpeditor/cpeditor/releases/download/6.3.3/cpeditor-full-source-6.3.3.tar.gz
md5sums = SKIP
pkgname = cpeditor
-
diff --git a/PKGBUILD b/PKGBUILD
index e6704a1b43bf..9e80accc5341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ashar Khan <ashar786khan at gmail.com>
pkgname=cpeditor
-pkgver=6.2.5
+pkgver=6.3.3
_pkgdir=cpeditor-full-source-$pkgver
pkgrel=1
pkgdesc='The editor for competitive programming'
@@ -9,7 +9,7 @@ arch=('x86_64')
url='https://github.com/cpeditor/cpeditor'
license=('GPL3')
depends=('qt5-base')
-makedepends=("cmake" "git" "gcc")
+makedepends=("cmake" "git" "gcc" "python3")
conflicts=("cpeditor-git")
source=("https://github.com/cpeditor/$pkgname/releases/download/$pkgver/cpeditor-full-source-$pkgver.tar.gz")
md5sums=('SKIP')
@@ -24,6 +24,3 @@ package() {
cd $_pkgdir/build
make DESTDIR="$pkgdir" install
}
-
-
-