summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21cd355ef035..ed4b03e048ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
# Generated by mksrcinfo v8
-# Tue Jun 7 21:41:10 UTC 2016
+# Wed Oct 26 14:43:08 UTC 2016
pkgbase = cppcheck-nox
pkgdesc = A tool for static C/C++ code analysis without the GUI
- pkgver = 1.74
+ pkgver = 1.76.1
pkgrel = 1
url = http://cppcheck.sourceforge.net/
arch = i686
arch = x86_64
license = GPL
makedepends = docbook-xsl
- makedepends = python
depends = python-pygments
- optdepends = pcre: searching regex with cppcheck
- source = https://github.com/danmar/cppcheck/archive/1.74.tar.gz
- sha256sums = a7f9657bf458190ea1c994b95333d31d09420198ad8cd010c05d2194cc547fa0
+ depends = pcre
+ source = https://github.com/danmar/cppcheck/archive/1.76.1.tar.gz
+ md5sums = 890f6076d66d97d9f0829a7357db84d8
pkgname = cppcheck-nox
diff --git a/PKGBUILD b/PKGBUILD
index 1592b852f064..6e2de8093202 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,24 @@
pkgname=cppcheck-nox
_pkgname=cppcheck
-pkgver=1.74
+pkgver=1.76.1
pkgrel=1
pkgdesc="A tool for static C/C++ code analysis without the GUI"
arch=('i686' 'x86_64')
url="http://cppcheck.sourceforge.net/"
license=('GPL')
-depends=('python-pygments')
-makedepends=('docbook-xsl' 'python')
-optdepends=('pcre: searching regex with cppcheck')
+depends=('python-pygments' 'pcre')
+makedepends=('docbook-xsl')
source=(https://github.com/danmar/cppcheck/archive/${pkgver}.tar.gz)
-sha256sums=('a7f9657bf458190ea1c994b95333d31d09420198ad8cd010c05d2194cc547fa0')
+md5sums=('890f6076d66d97d9f0829a7357db84d8')
build() {
cd "${_pkgname}-${pkgver}"
- # Unicode fix
+
LANG='en_US.UTF-8' make SRCDIR=build CFGDIR=/usr/share/cppcheck/cfg HAVE_RULES=yes
make DB2MAN=/usr/share/xml/docbook/xsl-stylesheets-1.79.1/manpages/docbook.xsl CFGDIR=/usr/share/cppcheck/cfg man
}
-check() {
- cd "${_pkgname}-${pkgver}"
- # LANG='en_US.UTF-8' make SRCDIR=build CFGDIR=/usr/share/cppcheck/cfg HAVE_RULES=yes test
-}
-
package() {
cd "${_pkgname}-${pkgver}"
LANG='en_US.UTF-8' make DESTDIR=${pkgdir} CFGDIR=/usr/share/cppcheck/cfg SRCDIR=build HAVE_RULES=yes install