summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f4600b15d22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cppdap-git
+ pkgdesc = C++ library for the Debug Adapter Protocol
+ pkgver = 1.59.0.r95.ge3379ed
+ pkgrel = 1
+ url = https://github.com/google/cppdap
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ provides = ccpdap
+ conflicts = ccpdap
+ source = git+https://github.com/google/cppdap
+ sha1sums = SKIP
+
+pkgname = cppdap-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b3d7126c1ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Piotr Gorski <lucjan.lucjanov@gmail.com>
+
+pkgname=cppdap-git
+pkgver=1.59.0.r95.ge3379ed
+pkgrel=1
+pkgdesc="C++ library for the Debug Adapter Protocol"
+arch=('x86_64')
+url='https://github.com/google/cppdap'
+license=('GPL')
+makedepends=('cmake' 'git')
+provides=('ccpdap')
+conflicts=('ccpdap')
+source=('git+https://github.com/google/cppdap')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd cppdap
+ _ver="$(cat CMakeLists.txt | grep -m1 '(cppdap VERSION' | grep -o "[[:digit:]]*" | paste -sd'.')"
+ echo "${_ver}.r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S cppdap \
+ -DCPPDAP_USE_EXTERNAL_NLOHMANN_JSON_PACKAGE=ON \
+ -DCPPDAP_USE_EXTERNAL_RAPIDJSON_PACKAGE=OFF \
+ -DCPPDAP_USE_EXTERNAL_JSONCPP_PACKAGE=OFF
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}