summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--patch12
3 files changed, 28 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74dc51a5b7a6..34447706a1a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cpulimit-git
pkgdesc = Limit cpu usage in %. Actualy sends SIGSTOP/SIGCONT
- pkgver = 92.49d7c69
- pkgrel = 2
+ pkgver = 113.f4d2682
+ pkgrel = 1
url = https://github.com/opsengine/cpulimit
arch = i686
arch = x86_64
@@ -10,8 +10,10 @@ pkgbase = cpulimit-git
depends = glibc
provides = cpulimit
conflicts = cpulimit
- source = cpulimit-git::git+git://github.com/opsengine/cpulimit.git
+ source = cpulimit-git::git+https://github.com/opsengine/cpulimit.git
+ source = patch
md5sums = SKIP
+ md5sums = 524d8ec2fa0d6f5c4e2f453929c94c3e
pkgname = cpulimit-git
diff --git a/PKGBUILD b/PKGBUILD
index 5e6b09dcc010..a3771695b889 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
# Maintainer: Mike Lenzen <lenzenmi@gmail.com>
pkgname=cpulimit-git
-pkgver=92.49d7c69
-pkgrel=2
+pkgver=113.f4d2682
+pkgrel=1
pkgdesc="Limit cpu usage in %. Actualy sends SIGSTOP/SIGCONT"
arch=('i686' 'x86_64')
url="https://github.com/opsengine/cpulimit"
@@ -18,9 +18,10 @@ depends=('glibc')
makedepends=('git')
provides=('cpulimit')
conflicts=('cpulimit')
-source=("$pkgname::git+git://github.com/opsengine/cpulimit.git")
+source=("$pkgname::git+https://github.com/opsengine/cpulimit.git" "patch")
-md5sums=('SKIP')
+md5sums=('SKIP'
+ '524d8ec2fa0d6f5c4e2f453929c94c3e')
pkgver() {
cd "$srcdir/$pkgname"
@@ -33,6 +34,12 @@ build() {
make
}
+# Patch to remove sysctl.h - removed from linxu
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch --forward --strip=1 --input="${srcdir}/patch"
+}
+
package() {
install -D -m0755 $srcdir/$pkgname/src/cpulimit $pkgdir/usr/bin/cpulimit
}
diff --git a/patch b/patch
new file mode 100644
index 000000000000..2cab9921771b
--- /dev/null
+++ b/patch
@@ -0,0 +1,12 @@
+Only in cpulimit-git: patch~
+diff --unified --recursive --text cpulimit-git/src/cpulimit.c cpulimit-git-patched/src/cpulimit.c
+--- cpulimit-git/src/cpulimit.c 2021-05-23 14:30:31.441532911 -0600
++++ cpulimit-git-patched/src/cpulimit.c 2021-05-23 14:29:24.612229881 -0600
+@@ -38,7 +38,6 @@
+ #include <string.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+-#include <sys/sysctl.h>
+ #include <sys/resource.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>