summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore28
-rw-r--r--.gitignore_append2
-rw-r--r--0001-Fix-compile-error-with-GCC-11.patch48
-rw-r--r--PKGBUILD18
5 files changed, 96 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 382cf50f8ed8..08704bf5d190 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cpuminer-multi-git
pkgdesc = Multi-algo CPUMiner & Reference Cryptonote Miner (JSON-RPC 2.0) - git version
- pkgver = 1.3.5.r20.gc207355
- pkgrel = 4
+ pkgver = 1.3.5.r27.g8ccbb81
+ pkgrel = 2
url = https://github.com/tpruvot/cpuminer-multi
arch = x86_64
license = GPL
@@ -13,7 +13,9 @@ pkgbase = cpuminer-multi-git
provides = cpuminer-multi
conflicts = cpuminer
source = git+https://github.com/tpruvot/cpuminer-multi.git
+ source = 0001-Fix-compile-error-with-GCC-11.patch
sha256sums = SKIP
+ sha256sums = 01f94fea8cc2753eee74a3d532b60d3e07319940f4b183bab80b5e9934009f92
pkgname = cpuminer-multi-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9803b006a93e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,28 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+# archlinuxpackages linux
+cpuminer-multi
diff --git a/.gitignore_append b/.gitignore_append
new file mode 100644
index 000000000000..f598827eaea1
--- /dev/null
+++ b/.gitignore_append
@@ -0,0 +1,2 @@
+# archlinuxpackages linux
+cpuminer-multi
diff --git a/0001-Fix-compile-error-with-GCC-11.patch b/0001-Fix-compile-error-with-GCC-11.patch
new file mode 100644
index 000000000000..cbd5cf7d2328
--- /dev/null
+++ b/0001-Fix-compile-error-with-GCC-11.patch
@@ -0,0 +1,48 @@
+From fcd5f2d0dd11c1c873c9e280c67a362d698aebc6 Mon Sep 17 00:00:00 2001
+From: 0x9fff00 <0x9fff00+git@protonmail.ch>
+Date: Wed, 26 May 2021 14:14:30 +0200
+Subject: [PATCH] Fix compile error with GCC 11
+
+Based on https://github.com/JayDDee/cpuminer-opt/commit/3c5e8921b764e03ef09c57b2207b9960d45123b0
+
+Co-authored-by: Jay D Dee <jayddee246@gmail.com>
+---
+ crypto/blake2s.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/crypto/blake2s.c b/crypto/blake2s.c
+index a20b746..0914b5a 100644
+--- a/crypto/blake2s.c
++++ b/crypto/blake2s.c
+@@ -323,7 +323,7 @@ int blake2s_final( blake2s_state *S, uint8_t *out, uint8_t outlen )
+
+ int blake2s( uint8_t *out, const void *in, const void *key, const uint8_t outlen, const uint64_t inlen, uint8_t keylen )
+ {
+- blake2s_state S[1];
++ blake2s_state S;
+
+ /* Verify parameters */
+ if ( NULL == in ) return -1;
+@@ -334,15 +334,15 @@ int blake2s( uint8_t *out, const void *in, const void *key, const uint8_t outlen
+
+ if( keylen > 0 )
+ {
+- if( blake2s_init_key( S, outlen, key, keylen ) < 0 ) return -1;
++ if( blake2s_init_key( &S, outlen, key, keylen ) < 0 ) return -1;
+ }
+ else
+ {
+- if( blake2s_init( S, outlen ) < 0 ) return -1;
++ if( blake2s_init( &S, outlen ) < 0 ) return -1;
+ }
+
+- blake2s_update( S, ( uint8_t * )in, inlen );
+- blake2s_final( S, out, outlen );
++ blake2s_update( &S, ( uint8_t * )in, inlen );
++ blake2s_final( &S, out, outlen );
+ return 0;
+ }
+
+--
+2.31.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 070139f470d2..196d6152173a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=cpuminer-multi
pkgname=$_pkgname-git
-pkgver=1.3.5.r20.gc207355
-pkgrel=4
+pkgver=1.3.5.r27.g8ccbb81
+pkgrel=2
pkgdesc='Multi-algo CPUMiner & Reference Cryptonote Miner (JSON-RPC 2.0) - git version'
arch=('x86_64')
url="https://github.com/tpruvot/$_pkgname"
@@ -13,8 +13,10 @@ depends=('curl' 'jansson' 'openssl')
makedepends=('git')
provides=('cpuminer' 'cpuminer-multi')
conflicts=('cpuminer')
-source=("git+$url.git")
-sha256sums=('SKIP')
+source=("git+$url.git"
+ '0001-Fix-compile-error-with-GCC-11.patch')
+sha256sums=('SKIP'
+ '01f94fea8cc2753eee74a3d532b60d3e07319940f4b183bab80b5e9934009f92')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -22,6 +24,14 @@ pkgver() {
git describe --long | sed 's/^v//;s/-multi-\([0-9]*-g[0-9A-Fa-f]*\)$/-r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ for p in "$srcdir"/*.patch; do
+ patch -Np1 -i "$p"
+ done
+}
+
build() {
cd "$srcdir/$_pkgname"