summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD29
3 files changed, 29 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c8c35e34f59..053843df5e13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = cpuset
- pkgdesc = Cpuset is a Python application to make using the cpusets facilities in the Linux kernel easier.
+ pkgdesc = Python app to make using the cpusets facilities in the Linux kernel easier
pkgver = 1.6
- pkgrel = 1
- url = https://github.com/lpechacek/cpuset/
+ pkgrel = 2
+ url = https://github.com/lpechacek/cpuset
arch = any
license = GPL2
- depends = python2
- depends = python2-future
- depends = python2-configparser
+ makedepends = python-setuptools
+ depends = python
options = !emptydirs
- source = https://github.com/lpechacek/cpuset/archive/v1.6.tar.gz
- md5sums = 365dcccfef9ac095530821a7e711b308
+ source = cpuset-1.6.tar.gz::https://github.com/lpechacek/cpuset/archive/v1.6.tar.gz
+ b2sums = 389c274981fe9a23188da71ce0fbc1e0bcdfe6dbe0108bf45659511cbbf711022108914e16aa679c0934f9a5a06b69129738d5f85e96aeb7604cef9c840133a3
pkgname = cpuset
-
diff --git a/.gitignore b/.gitignore
index 4f752c559aa4..713f6f80aff8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
-src/
-pkg/
-*.xz
+/*
+!/.gitignore
+!/.SRCINFO
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index bb342d58812d..7a32812cbff8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,24 @@
-# Maintainer: Jon Gjengset <jon@thesquareplanet.com>, Saren Arterius <saren@wtako.net>
+# Maintainer: éclairevoyant
+
pkgname=cpuset
pkgver=1.6
-pkgrel=1
-pkgdesc="Cpuset is a Python application to make using the cpusets facilities in the Linux kernel easier."
-arch=('any')
-url="https://github.com/lpechacek/cpuset/"
-license=('GPL2')
-depends=('python2' 'python2-future' 'python2-configparser')
+pkgrel=2
+pkgdesc="Python app to make using the cpusets facilities in the Linux kernel easier"
+arch=(any)
+url="https://github.com/lpechacek/$pkgname"
+license=(GPL2)
+depends=(python)
+makedepends=(python-setuptools)
options=('!emptydirs')
-source=("https://github.com/lpechacek/cpuset/archive/v${pkgver}.tar.gz")
-md5sums=('365dcccfef9ac095530821a7e711b308')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+b2sums=('389c274981fe9a23188da71ce0fbc1e0bcdfe6dbe0108bf45659511cbbf711022108914e16aa679c0934f9a5a06b69129738d5f85e96aeb7604cef9c840133a3')
+
+build() {
+ cd $pkgname-$pkgver
+ python setup.py build
+}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ cd $pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}