summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--timezone.patch12
3 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7e9dc8608f5..91239cf1ea5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = crane-gps-watch-git
pkgdesc = Linux client for Crane gps watch (from Aldi or Hofer). It reads from the watch and writes to '.tcx', Garmin Training Center file.
- pkgver = 20150519
+ pkgver = 20150806
pkgrel = 1
url = https://github.com/mru00/crane_gps_watch
arch = any
@@ -11,7 +11,9 @@ pkgbase = crane-gps-watch-git
conflicts = crane-gps-watch
options = !emptydirs
source = git://github.com/mru00/crane_gps_watch.git
+ source = timezone.patch
md5sums = SKIP
+ md5sums = 1a94591f03be329b84f28c4570064223
pkgname = crane-gps-watch-git
diff --git a/PKGBUILD b/PKGBUILD
index 53e8a6492daa..f72dfb31e19e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
pkgname=crane-gps-watch-git
_pkgname=crane_gps_watch
-pkgver=20150519
+pkgver=20150806
pkgrel=1
pkgdesc="Linux client for Crane gps watch (from Aldi or Hofer). It reads from the watch and writes to '.tcx', Garmin Training Center file."
arch=('any')
url="https://github.com/mru00/crane_gps_watch"
-source="git://github.com/mru00/crane_gps_watch.git"
+source=("git://github.com/mru00/crane_gps_watch.git"
+ 'timezone.patch')
license=('GPL')
depends=('libxml2')
makedepends=('git')
provides=('crane-gps-watch')
conflicts=('crane-gps-watch')
options=('!emptydirs')
-md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -21,7 +21,7 @@ pkgver() {
package(){
cd "$srcdir/$_pkgname"
-
+ patch -p1 < $srcdir/timezone.patch
# CXXFLAGS="$CXXFLAGS -Wno-error=maybe-uninitialized"
# CFLAGS="$CFLAGS -Wno-error=maybe-uninitialized"
aclocal || return 1
@@ -32,4 +32,6 @@ package(){
# install -d "${pkgdir}"/usr/bin
# install -Dm755 "${srcdir}/${_pkgname}/crane_gps_watch_client" "${pkgdir}/usr/bin/crane_gps_watch_client"
-} \ No newline at end of file
+}
+md5sums=('SKIP'
+ '1a94591f03be329b84f28c4570064223')
diff --git a/timezone.patch b/timezone.patch
new file mode 100644
index 000000000000..7d115f87e1a5
--- /dev/null
+++ b/timezone.patch
@@ -0,0 +1,12 @@
+diff -Naur crane_gps_watch/src/DataTypes.cpp crane_gps_watch.new/src/DataTypes.cpp
+--- crane_gps_watch/src/DataTypes.cpp 2015-08-10 13:54:35.572844140 +0200
++++ crane_gps_watch.new/src/DataTypes.cpp 2015-08-10 13:55:49.030905363 +0200
+@@ -60,7 +60,7 @@
+ light saving time is in effect, zero if it is not, and nega‐$
+ tive if the information is not available.$
+ */
+- time.tm_isdst = 0;
++ time.tm_isdst = -1;
+ }
+
+ GpsTime& GpsTime::operator=(const GpsTimeUpd& other) {