summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
2 files changed, 22 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33358432dec3..34ae1cc3b78b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,25 +6,18 @@ pkgbase = crema-git
arch = any
license = GPL3
makedepends = git
+ makedepends = go
makedepends = make
makedepends = pandoc
- makedepends = m4
depends = binutils
depends = devtools
+ depends = git
+ depends = pacman
depends = rsync
depends = sudo
- depends = jq
- depends = pacutils
- depends = parallel
- depends = wget
optdepends = gnupg
- optdepends = bash-completion: bash completion
- optdepends = devtools: aur-chroot
- optdepends = vifm: build file interaction
provides = crema
- conflicts = crema
- conflicts = aurutils
- conflicts = aurutils-git
+ conflicts = crema-git
source = git+https://gitlab.com/mipimipi/crema.git
validpgpkeys = 11ECD6695134183B3E7AF1C2223AAA374A1D59CE
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4bca1872c3e0..3d7cc681ca99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,8 @@
# Maintainer: Michael Picht <mipi@fsfe.org>
+#
+# SPDX-FileCopyrightText: 2018-2020 Michael Picht <mipi@fsfe.org>
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
_pkgorg=gitlab.com/mipimipi
pkgname=crema-git
@@ -15,35 +19,33 @@ md5sums=(SKIP)
depends=(
binutils
devtools
+ git
+ pacman
rsync
sudo
)
makedepends=(
git
+ go
make
pandoc
)
optdepends=(gnupg)
provides=(crema)
-conflicts=(crema)
+conflicts=(crema-git)
-# aurutils
-conflicts+=(
- aurutils
- aurutils-git
-)
depends+=(
- jq
- pacutils
- parallel
- wget
-)
-makedepends+=(m4)
-optdepends+=(
- "bash-completion: bash completion"
- "devtools: aur-chroot"
- "vifm: build file interaction"
+# jq
+# pacutils
+# parallel
+# wget
)
+#makedepends+=(m4)
+#optdepends+=(
+# "bash-completion: bash completion"
+# "devtools: aur-chroot"
+# "vifm: build file interaction"
+#)
pkgver() {
cd "$srcdir/$_pkgname"
@@ -53,17 +55,9 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname"
make
-
- # aurutils
- cd aurutils
- make DESTDIR="$pkgdir"
}
package() {
cd "$srcdir/$_pkgname"
make DESTDIR="$pkgdir" install
-
- # aurutils
- cd aurutils
- make DESTDIR="$pkgdir" install
}