summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53144e9177fa..05e25f3a1fff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = crfsuite
pkgdesc = An implementation of Conditional Random Fields (CRFs) for labeling sequential data.
pkgver = 0.12
- pkgrel = 1
+ pkgrel = 2
url = http://www.chokkan.org/software/crfsuite/
arch = i686
arch = x86_64
license = custom:BSD
depends = liblbfgs
- source = https://github.com/downloads/chokkan/crfsuite/crfsuite-0.12.tar.gz
- md5sums = 3fb2033066996921e7979e35ab1a570f
+ source = https://github.com/mistersmee/crfsuite/archive/refs/tags/0.12-1.tar.gz
+ md5sums = 4a8ca0f18c768bdb8e65c2bf039ccc8e
pkgname = crfsuite
-
diff --git a/PKGBUILD b/PKGBUILD
index 0d3660ac7944..7fbaf93c6d51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
-# Maintainer: Tavian Barnes <tavianator@tavianator.com>
+# Maintainer: Aseem Athale <athaleaseem@gmail.com>
+# Contributor: Tavian Barnes <tavianator@tavianator.com>
# Contributor: ngukho <ngukho at gmail dot com>
pkgname=crfsuite
pkgver=0.12
-pkgrel=1
+pkgrel=2
pkgdesc="An implementation of Conditional Random Fields (CRFs) for labeling sequential data."
arch=('i686' 'x86_64')
url="http://www.chokkan.org/software/crfsuite/"
license=('custom:BSD')
depends=('liblbfgs')
-source=("https://github.com/downloads/chokkan/crfsuite/$pkgname-$pkgver.tar.gz")
-md5sums=('3fb2033066996921e7979e35ab1a570f')
+source=("https://github.com/mistersmee/crfsuite/archive/refs/tags/$pkgver-1.tar.gz")
+md5sums=('4a8ca0f18c768bdb8e65c2bf039ccc8e')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver-1"
+ ./autogen.sh
./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$pkgname-$pkgver-1"
make DESTDIR="$pkgdir/" install