summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c70a4d6ba18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed May 8 16:24:07 UTC 2019
+pkgbase = crowdin-cli-py
+ pkgdesc = python based crowdin command line tool
+ pkgver = 0.95.6
+ pkgrel = 1
+ url = https://github.com/PaulGregor/crowdin-cli
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pyaml
+ source = https://files.pythonhosted.org/packages/source/c/crowdin-cli-py/crowdin-cli-py-0.95.6.zip
+ sha512sums = 876455971bd22a8e94bbd92a467a59796bc23b086520666ec1a639acd29f12fd195d2b95c1eb9aa1ad80ac671033d1448c4d8bd1b42a9bb9c990cccd7c42c558
+
+pkgname = crowdin-cli-py
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9e530204a82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# maintainer Storm Dragon <stormdragon2976@gmail.com>
+
+pkgname='crowdin-cli-py'
+pkgver=0.95.6
+pkgrel=1
+pkgdesc="python based crowdin command line tool"
+arch=('any')
+url="https://github.com/PaulGregor/crowdin-cli"
+license=('MIT')
+depends=('python' 'python-pyaml')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.zip")
+sha512sums=('876455971bd22a8e94bbd92a467a59796bc23b086520666ec1a639acd29f12fd195d2b95c1eb9aa1ad80ac671033d1448c4d8bd1b42a9bb9c990cccd7c42c558')
+
+build() {
+ cd "$srcdir"/${pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: