summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45082b6cabd5..50b9266901da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = cruft
pkgdesc = Maintain all the necessary boilerplate for packaging and building projects separate from the code you intentionally write. Fully compatible with existing Cookiecutter templates
- pkgver = 2.12.0
+ pkgver = 2.15.0
pkgrel = 1
url = https://cruft.github.io/cruft/
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-poetry
depends = python
depends = python-click
depends = python-cookiecutter
depends = python-gitpython
depends = python-typer
optdepends = python-toml: specify patterns to ignore in toml files
- source = https://files.pythonhosted.org/packages/source/c/cruft/cruft-2.12.0.tar.gz
- sha1sums = caa92f51a79e1f3b21f8345f89afd01fda2698a7
- sha256sums = 57455d33a60684c945d501dcea2b1c57dc0fb200a0090f07c83da1603382cbb1
+ source = https://files.pythonhosted.org/packages/source/c/cruft/cruft-2.15.0.tar.gz
+ sha1sums = 312b0312ad460dd70ea8d55d1664e2819e47d728
+ sha256sums = 9802af66037418655e7e4b6f30b531591e0761939b3ff5dd45d27c3a3f588abe
pkgname = cruft
diff --git a/PKGBUILD b/PKGBUILD
index 4d8d25f6369c..13bcbb4a21cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: nblock <nblock [/at\] archlinux DOT us>
pkgname=cruft
-pkgver=2.12.0
+pkgver=2.15.0
pkgrel=1
pkgdesc='Maintain all the necessary boilerplate for packaging and building projects separate from the code you intentionally write. Fully compatible with existing Cookiecutter templates'
arch=('any')
@@ -13,20 +13,20 @@ depends=('python'
'python-gitpython'
'python-typer')
optdepends=('python-toml: specify patterns to ignore in toml files')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-poetry')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha1sums=('caa92f51a79e1f3b21f8345f89afd01fda2698a7')
-sha256sums=('57455d33a60684c945d501dcea2b1c57dc0fb200a0090f07c83da1603382cbb1')
+sha1sums=('312b0312ad460dd70ea8d55d1664e2819e47d728')
+sha256sums=('9802af66037418655e7e4b6f30b531591e0761939b3ff5dd45d27c3a3f588abe')
build() {
cd "$pkgname-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$pkgname-$pkgver"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim:set ts=2 sw=2 noet: