summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 26 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6623fd6fd365..b69cea0748ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = csky-debugserver-bin
pkgdesc = C-Sky Debugger Server
- pkgver = 5.12.1
- pkgrel = 2
- url = https://occ.t-head.cn/community/download?id=616215132330000384
+ pkgver = 5.16.11
+ pkgrel = 1
+ url = https://occ.t-head.cn/community/download?id=41336344657653
arch = x86_64
license = BSD
- makedepends = tar
+ makedepends = libarchive
depends = bash
options = !strip
- source = csky-debugserver-bin-5.12.1.tar.gz::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1836682/1626764200205/T-Head-DebugServer-linux-x86_64-V5.12.1-20210716.sh.tar.gz
+ source = T-Head Debugger Server User Guide ZH-CN v5.16.pdf::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource//1659579718572/T-Head+Debugger+Server+User+Guide+%28ZH-CN%29_v5.16.pdf
+ source = csky-debugserver-bin-5.16.11.sh.tar.gz::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource//1691553051819/T-Head-DebugServer-linux-x86_64-V5.16.11-20230803.sh.tar.gz
source = DebugServer User Guide_v5.10.pdf::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1355977/1588909480730/C-Sky+Debugger+Server+User+Guide_v5.10.pdf
source = DebugServer User Guide v5.6.pdf::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1355977/1588916696490/C-Sky+Debugger+Server+User+Guide+v5.6.pdf
- sha256sums = 054dd396aaf13adf409e31e2ad64e408843f27b892ed5175625bc1a3c781ff75
+ sha256sums = 2b64d17b6589ec5252ad610a79ba15857cc3257c970d3a0dee61d0358dca7162
+ sha256sums = b6af02ab6dbd89e5cbd73fa153ebded9bb6d4730e58c588d165f61768b376e61
sha256sums = 6a004189c409a66f550c676990c637b08cbad5f928fed6e0309caf95fe1e62c2
sha256sums = 6a004189c409a66f550c676990c637b08cbad5f928fed6e0309caf95fe1e62c2
diff --git a/PKGBUILD b/PKGBUILD
index 6da6aed00f84..cfea6bc5aea1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,47 @@
# Maintainer: taotieren <admin@taotieren.com>
pkgname=csky-debugserver-bin
-pkgver=5.12.1
-pkgrel=2
+pkgver=5.16.11
+pkgrel=1
epoch=
pkgdesc="C-Sky Debugger Server"
arch=('x86_64')
-url="https://occ.t-head.cn/community/download?id=616215132330000384"
+url="https://occ.t-head.cn/community/download?id=41336344657653"
license=('BSD')
groups=()
-depends=('bash')
-makedepends=("tar")
+depends=(bash)
+makedepends=(libarchive)
checkdepends=()
optdepends=()
provides=()
conflicts=()
replaces=()
backup=()
-options=('!strip')
+options=(!strip)
install=
changelog=
-source=(
- "${pkgname}-${pkgver}.tar.gz::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1836682/1626764200205/T-Head-DebugServer-linux-x86_64-V5.12.1-20210716.sh.tar.gz"
+source=("T-Head Debugger Server User Guide ZH-CN v5.16.pdf::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource//1659579718572/T-Head+Debugger+Server+User+Guide+%28ZH-CN%29_v5.16.pdf"
+ "${pkgname}-${pkgver}.sh.tar.gz::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource//1691553051819/T-Head-DebugServer-linux-x86_64-V5.16.11-20230803.sh.tar.gz"
"DebugServer User Guide_v5.10.pdf::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1355977/1588909480730/C-Sky+Debugger+Server+User+Guide_v5.10.pdf"
"DebugServer User Guide v5.6.pdf::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1355977/1588916696490/C-Sky+Debugger+Server+User+Guide+v5.6.pdf")
noextract=()
-sha256sums=('054dd396aaf13adf409e31e2ad64e408843f27b892ed5175625bc1a3c781ff75'
+sha256sums=('2b64d17b6589ec5252ad610a79ba15857cc3257c970d3a0dee61d0358dca7162'
+ 'b6af02ab6dbd89e5cbd73fa153ebded9bb6d4730e58c588d165f61768b376e61'
'6a004189c409a66f550c676990c637b08cbad5f928fed6e0309caf95fe1e62c2'
'6a004189c409a66f550c676990c637b08cbad5f928fed6e0309caf95fe1e62c2')
#validpgpkeys=()
-prepare(){
-# Decrypt gzexe encrypted shell script
-# Origin file 92 Line: tail -n +$LNUM $0 > tmp.tar.gz
- tail -n +282 "${srcdir}"/*.sh > "${srcdir}/${pkgname}-${pkgver}.gz"
-}
-
package() {
+ tail -n +282 "${srcdir}"/*${pkgver}*.sh > "${srcdir}/${pkgname}-${pkgver}.tar.gz"
+
install -dm0755 "${pkgdir}/opt/t-head/${pkgname%-bin}"
- tar -xf "${srcdir}/${pkgname}-${pkgver}.gz" --no-same-owner --no-same-permissions --strip-components=1 -C "${pkgdir}/opt/t-head/${pkgname%-bin}"
- cp -r "${srcdir}"/*.pdf "${pkgdir}/opt/t-head/${pkgname%-bin}"
- install -Dm0644 /dev/stdin "${pkgdir}/etc/ld.so.conf.d/${pkgname%-bin}.conf" << EOF
-/opt/t-head/${pkgname%-bin}
+ bsdtar -xf "${srcdir}/${pkgname}-${pkgver}.tar.gz" --no-same-owner --no-same-permissions --strip-components=1 -C "${pkgdir}/opt/t-head/${pkgname%-bin}"
+
+ install -Dm0644 "${srcdir}"/*.pdf -t "${pkgdir}/opt/t-head/${pkgname%-bin}"
+
+ install -Dm0644 /dev/stdin "${pkgdir}/etc/profile.d/${pkgname%-bin}.csh" << EOF
+setenv PATH "${PATH}:/opt/t-head/${pkgname%-bin}"
EOF
install -Dm0755 /dev/stdin "${pkgdir}/usr/bin/${pkgname%-bin}" << EOF