summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--python_install_dir.patch16
3 files changed, 8 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b00579395fa..545b8db9892d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Oct 22 03:07:36 UTC 2017
+# Sat Dec 23 04:27:59 UTC 2017
pkgbase = csound
pkgdesc = A programming language for sound rendering and signal processing.
- pkgver = 6.09.1
- pkgrel = 3
+ pkgver = 6.10.0
+ pkgrel = 1
url = http://csound.github.io
arch = i686
arch = x86_64
@@ -33,11 +33,9 @@ pkgbase = csound
optdepends = java-environment: Java Wrapper
optdepends = vim-csound: Syntax Highlighting and Bindings for Vim
conflicts = libextractor
- source = https://github.com/csound/csound/archive/6.09.1.tar.gz
- source = python_install_dir.patch
+ source = https://github.com/csound/csound/archive/6.10.0.tar.gz
source = csound.sh
- sha256sums = e4d2e9870d3b29305c9bc404dc93806e61420a57fc4bc69577676b4934c71777
- sha256sums = 9c13a6d416294f073e481db934c6a816170af012d3b5b8707d8699deb29bee89
+ sha256sums = a241043521572d00ae3a926611ac52fd6a7e3fe6bafdbe707867aafe32f6d8a3
sha256sums = 23db5bda78f13d5f16eceea085bba660d7b7012a89518e477d12dfef82dbadeb
pkgname = csound
diff --git a/PKGBUILD b/PKGBUILD
index dd89e1d559c2..cc9b98a1d5c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Bernardo Barros
pkgname=csound
-pkgver=6.09.1
-pkgrel=3
+pkgver=6.10.0
+pkgrel=1
pkgdesc="A programming language for sound rendering and signal processing."
arch=('i686' 'x86_64')
url="http://csound.github.io"
@@ -18,18 +18,10 @@ optdepends=('csound-doc: The Canonical Csound Reference Manual'
# Both Libextractor and Csound install /usr/bin/extractor
conflicts=('libextractor')
source=("https://github.com/csound/csound/archive/${pkgver}.tar.gz"
- "python_install_dir.patch"
"csound.sh")
-sha256sums=('e4d2e9870d3b29305c9bc404dc93806e61420a57fc4bc69577676b4934c71777'
- '9c13a6d416294f073e481db934c6a816170af012d3b5b8707d8699deb29bee89'
+sha256sums=('a241043521572d00ae3a926611ac52fd6a7e3fe6bafdbe707867aafe32f6d8a3'
'23db5bda78f13d5f16eceea085bba660d7b7012a89518e477d12dfef82dbadeb')
-prepare() {
- # 6.09.1 tries to install python modules in the home dir.
- # https://github.com/csound/csound/issues/828#issuecomment-315856126
- patch -d "csound-$pkgver" -p1 < python_install_dir.patch
-}
-
build() {
cd "csound-${pkgver}"
mkdir -p bld && cd bld
diff --git a/python_install_dir.patch b/python_install_dir.patch
deleted file mode 100644
index cc27ff9b8c16..000000000000
--- a/python_install_dir.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f97541b..3559826 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -221,9 +221,11 @@ endif()
- execute_process (
- COMMAND python -c
- "import site, sys; sys.stdout.write(site.getusersitepackages())"
-- OUTPUT_VARIABLE PYTHON_MODULE_INSTALL_DIR
-+ OUTPUT_VARIABLE PYTHON_USER_SITE_PACKAGES
- )
-
-+SET(PYTHON_MODULE_INSTALL_DIR ${PYTHON_USER_SITE_PACKAGES} CACHE PATH "/usr/lib/python2.7/site-packages")
-+
- set(JAVA_MODULE_INSTALL_DIR ${LIBRARY_INSTALL_DIR})
- set(LUA_MODULE_INSTALL_DIR ${LIBRARY_INSTALL_DIR})