summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1088f05b5529..ca25da1037e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,11 @@ pkgdesc="A programming language for sound rendering and signal processing."
arch=('i686' 'x86_64')
url="http://csound.github.io"
license=('LGPL')
-depends=('fltk' 'fluidsynth' 'liblo' 'portaudio' 'portmidi' 'tk' 'curl' 'stk' 'luajit')
+depends=('fltk' 'fluidsynth' 'liblo' 'portaudio' 'portmidi' 'tk' 'curl' 'stk' 'luajit' 'python2')
makedepends=('pd' 'cmake' 'gmm' 'swig' 'java-environment' 'dssi' 'boost' 'luajit' 'eigen')
optdepends=('csound-doc: The Canonical Csound Reference Manual'
'csoundqt: Qt frontend'
'java-environment: Java Wrapper'
- 'python2: csnd6 python bindings'
'vim-csound: Syntax Highlighting and Bindings for Vim')
source=("https://github.com/csound/csound/archive/${pkgver}.tar.gz"
"Custom.cmake"
@@ -30,7 +29,9 @@ prepare() {
build() {
cd "csound-${pkgver}"
mkdir -p bld && cd bld
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so
make
}