summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e1c877957f2..8473b4dc66ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = csound
pkgdesc = A programming language for sound rendering and signal processing.
- pkgver = 6.05
+ pkgver = 6.05.0
pkgrel = 1
url = http://csound.github.io
arch = i686
@@ -29,9 +29,9 @@ pkgbase = csound
optdepends = vim-csound: Syntax Highlighting and Bindings for Vim
optdepends = java-environment: Java Wrapper
optdepends = csound-doc: The Canonical Csound Reference Manual
- source = http://downloads.sourceforge.net/project/csound/csound6/Csound6.05/Csound6.05.tar.gz
+ source = https://github.com/csound/csound/archive/6.05.0.tar.gz
source = csound.sh
- sha256sums = 0d0ab4c1804265f4947e07c5e41ee72bc1a122b873bd77b9e7179f4c4db43a28
+ sha256sums = 2384cbc82fe37b70192c87977b52c55b336731ecbfd3be1d8d30c7223815d7b9
sha256sums = 23db5bda78f13d5f16eceea085bba660d7b7012a89518e477d12dfef82dbadeb
pkgname = csound
diff --git a/PKGBUILD b/PKGBUILD
index 8f6573ae7662..db682f55cb52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Ainola <opp310@alh.rqh> (ROT13 this.)
-# Contributor: speps <speps at aur dot archlinux dot org>
-# Contributor: Bernardo Barros <bernardobarros@gmail.com>
+# Maintainer: Ainola
+# Contributor: speps
+# Contributor: Bernardo Barros
pkgname=csound
-pkgver=6.05
+pkgver=6.05.0
pkgrel=1
pkgdesc="A programming language for sound rendering and signal processing."
arch=('i686' 'x86_64')
@@ -15,13 +15,13 @@ optdepends=('csoundqt: Qt frontend'
'vim-csound: Syntax Highlighting and Bindings for Vim'
'java-environment: Java Wrapper'
'csound-doc: The Canonical Csound Reference Manual')
-source=("http://downloads.sourceforge.net/project/csound/csound${pkgver:0:1}/Csound${pkgver:0:4}/Csound${pkgver}.tar.gz"
+source=("https://github.com/csound/csound/archive/${pkgver}.tar.gz"
"csound.sh")
-sha256sums=('0d0ab4c1804265f4947e07c5e41ee72bc1a122b873bd77b9e7179f4c4db43a28'
+sha256sums=('2384cbc82fe37b70192c87977b52c55b336731ecbfd3be1d8d30c7223815d7b9'
'23db5bda78f13d5f16eceea085bba660d7b7012a89518e477d12dfef82dbadeb')
prepare() {
- cd "Csound${pkgver}"
+ cd "csound-${pkgver}"
# install modules to proper paths
sed -i '/^set.*MODULE_INSTALL_DIR/d' CMakeLists.txt
@@ -30,7 +30,7 @@ prepare() {
}
build() {
- cd "Csound${pkgver}"
+ cd "csound-${pkgver}"
mkdir -p bld && cd bld
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DPYTHON_MODULE_INSTALL_DIR=/usr/lib/python2.7/site-packages \
@@ -41,7 +41,7 @@ build() {
}
package() {
- cd "Csound${pkgver}/bld"
+ cd "csound-${pkgver}/bld"
make DESTDIR="$pkgdir/" install
# export vars in profile.d