summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b40318d2ffa1..1036844af07b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = cspice
pkgdesc = A comprehensive toolkit and api to design, simulate and analyse space missions
pkgver = N0066
- pkgrel = 1
+ pkgrel = 2
url = https://naif.jpl.nasa.gov/naif/aboutspice.html
arch = x86_64
makedepends = tcsh
depends = glibc
+ depends = f2c
source = http://naif.jpl.nasa.gov/pub/naif/toolkit//C/PC_Linux_GCC_64bit/packages/cspice.tar.Z
sha1sums = bb1bee61522e4fac18b68364362270b4eb2f3fd8
diff --git a/PKGBUILD b/PKGBUILD
index 3007907c2a19..fd806d7245b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
+
# Maintainer: BrainDamage <braindamage springlobby.info>
pkgname=cspice
pkgver="N0066"
-pkgrel=1
+pkgrel=2
pkgdesc="A comprehensive toolkit and api to design, simulate and analyse space missions"
arch=("x86_64")
url="https://naif.jpl.nasa.gov/naif/aboutspice.html"
-depends=("glibc")
+depends=("glibc" "f2c")
makedepends=("tcsh")
source=("http://naif.jpl.nasa.gov/pub/naif/toolkit//C/PC_Linux_GCC_64bit/packages/cspice.tar.Z")
sha1sums=('bb1bee61522e4fac18b68364362270b4eb2f3fd8')
@@ -27,4 +28,5 @@ package() {
cp -R exe "$pkgdir/usr/bin"
cp -R include "$pkgdir/usr/"
cp -R lib "$pkgdir/usr/"
+ rm "$pkgdir/usr/include/f2c.h" #we remove the vendorized header and rely on the library package to supply it instead
}