summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
2 files changed, 12 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39d1293bd4d5..141b103fe90c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ctf-recon-utils
- pkgdesc = Some scripts that make CTF Reconnaisance alot more straightforward.
- pkgver = 1.0
- pkgrel = 1
+ pkgdesc = Some scripts that make CTF Reconnaisance a bit more straightforward.
+ pkgver = 1.0.0
+ pkgrel = 1.1
url = https://github.com/AmeliaYeah/ctf-recon-utils
arch = x86_64
license = GPL
@@ -10,9 +10,10 @@ pkgbase = ctf-recon-utils
depends = nikto
depends = curl
depends = nmap
- depends = git
depends = python3
depends = python-pip
optdepends = libnotify
+ source = https://github.com/AmeliaYeah/ctf-recon-utils/archive/refs/tags/v1.0.0.tar.gz
+ md5sums = SKIP
pkgname = ctf-recon-utils
diff --git a/PKGBUILD b/PKGBUILD
index faa7451111fa..9e07b104e5dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,15 @@
# Maintainer: Amelia (AmeliaYeah@aur.archlinux.org)
pkgname='ctf-recon-utils'
-pkgver=1.0
-pkgrel=1
-pkgdesc="Some scripts that make CTF Reconnaisance alot more straightforward."
+pkgver="1.0.0"
+pkgrel=1.1
+pkgdesc="Some scripts that make CTF Reconnaisance a bit more straightforward."
arch=('x86_64')
url="https://github.com/AmeliaYeah/ctf-recon-utils"
license=('GPL')
-depends=('ffuf' 'gobuster' 'nikto' 'curl' 'nmap' 'git' 'python3' 'python-pip')
+depends=('ffuf' 'gobuster' 'nikto' 'curl' 'nmap' 'python3' 'python-pip')
optdepends=('libnotify')
-
-prepare() {
- echo "Cloning github repository..."
- git clone "$url" "$srcdir/ctf-recon"
-}
+source=("https://github.com/AmeliaYeah/ctf-recon-utils/archive/refs/tags/v${pkgver}.tar.gz")
+md5sums=('SKIP')
package() {
echo "Making the package directories..."
@@ -23,14 +20,10 @@ package() {
export base_dir
echo "Moving into the cloned repository..."
- git_repo="$srcdir/ctf-recon"
+ git_repo="$srcdir/ctf-recon-utils-${pkgver}"
cd "$git_repo"
echo "Running the install script..."
chmod +x ./install.sh
./install.sh
-
- echo "Cleaning out the repository..."
- cd "$srcdir"
- rm -rf "$git_repo"
}