summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--Imakefile.local114
-rw-r--r--PKGBUILD38
-rw-r--r--copyright13
4 files changed, 190 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..742a78b611aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = ctwm
+ pkgdesc = Richard's Tab Window Manager
+ pkgver = 3.8.2
+ pkgrel = 1
+ url = http://ctwm.org/
+ arch = x86_64
+ arch = i686
+ license = custom:MIT
+ license = custom:X
+ makedepends = imake
+ makedepends = setconf
+ depends = glibc
+ depends = libjpeg-turbo
+ depends = libxmu
+ depends = libxpm
+ backup = etc/X11/ctwm/system.ctwmrc
+ source = http://ctwm.org/dist/ctwm-3.8.2.tar.xz
+ source = Imakefile.local
+ source = copyright
+ sha256sums = 574d67a8a69f2f1ebaa71aa40cc50667e814f74b51f5db8886e2def6a3e0900f
+ sha256sums = ba8b25071ba0cdf03299dd827296b0fd8a6e549dac6f1ce8d50d9f26afd17041
+ sha256sums = 5242dcee1ffc736abd3e7022648c51039da7f4d998a2eb1eaee57367816886c1
+
+pkgname = ctwm
+
diff --git a/Imakefile.local b/Imakefile.local
new file mode 100644
index 000000000000..1c62ea804a1b
--- /dev/null
+++ b/Imakefile.local
@@ -0,0 +1,114 @@
+XCOMM This is the local configuration file for Imakefile for ctwm.
+XCOMM
+XCOMM Some of the things you can define also come with make variables that
+XCOMM can be manipulated. All such variables have names starting with\
+XCOMM USER_.
+
+XCOMM ----------------------------------------------------------------------
+XCOMM Feature: Use IMCONV features.
+XCOMM Uhmm, I really don't know what this is about. -- Richard Levitte
+XCOMM
+XCOMM The make variables USER_IMCONVLIBDIR and USER_IMCONVINCDIR can be
+XCOMM used to configure library search paths and include file search paths
+XCOMM to find the imconv libraries and header files.
+XCOMM
+XCOMM Example:
+XCOMM
+XCOMM #define IMCONV
+XCOMM USER_IMCONVLIBDIR = -L/logiciels/public/graphix/lib
+XCOMM USER_IMCONVINCDIR = -I/logiciels/public/graphix/include
+XCOMM
+#undef IMCONV
+
+XCOMM ----------------------------------------------------------------------
+XCOMM Feature: Use sounds
+XCOMM If you want sound support through librplay, defined USE_SOUND.
+XCOMM
+XCOMM The make variables USER_SOUNDLIBDIR and USER_SOUNDINCDIR can be
+XCOMM used to configure library search paths and include file search paths
+XCOMM to find the rplay libraries and header files.
+XCOMM
+XCOMM Example:
+XCOMM
+XCOMM #define USE_SOUND
+XCOMM USER_SOUNDLIBDIR = -L/usr/lib
+XCOMM USER_SOUNDINCDIR = -I/usr/include
+XCOMM
+#undef USE_SOUND
+
+XCOMM ----------------------------------------------------------------------
+XCOMM Feature: Use XPM images
+XCOMM If you want XPM support, define XPM.
+XCOMM
+XCOMM The make variables USER_XPMLIBDIR and USER_XPMINCDIR can be
+XCOMM used to configure library search paths and include file search paths
+XCOMM to find the xpm libraries and header files.
+XCOMM
+XCOMM Example:
+XCOMM
+XCOMM #define XPM
+XCOMM USER_XPMLIBDIR = -L/usr/lib
+XCOMM USER_XPMINCDIR = -I/usr/include
+XCOMM
+#define XPM
+
+XCOMM ----------------------------------------------------------------------
+XCOMM Feature: Use Jpeg images
+XCOMM If you want JPEG support, define JPEG.
+XCOMM
+XCOMM The make variables USER_JPEGLIBDIR and USER_JPEGINCDIR can be
+XCOMM used to configure library search paths and include file search paths
+XCOMM to find the jpeg libraries and header files.
+XCOMM
+XCOMM Example:
+XCOMM
+XCOMM #define JPEG
+XCOMM USER_JPEGLIBDIR = -L/usr/lib
+XCOMM USER_JPEGINCDIR = -I/usr/include
+XCOMM
+#define JPEG
+
+XCOMM ----------------------------------------------------------------------
+XCOMM Feature: Using M4 to process the ctwm configuration file
+XCOMM If you want to process the ctwm configuration file with m4, define
+XCOMM USE_M4.
+XCOMM
+#define USE_M4
+
+XCOMM ----------------------------------------------------------------------
+XCOMM Feature: Support for Gnome extensions
+XCOMM If you want to build with Gnome extensions, define GNOME.
+XCOMM
+#define GNOME
+
+XCOMM ----------------------------------------------------------------------
+XCOMM Feature: Use GNU regex
+XCOMM If you want to build with GNU regex instead of the internal regex
+XCOMM functions, define USE_GNU_REGEX.
+XCOMM
+#undef USE_GNU_REGEX
+
+XCOMM DEBUGGING:
+
+XCOMM ----------------------------------------------------------------------
+XCOMM Feature: General debugging
+XCOMM If you want to get all kinds of debugging output from CTWM, define
+XCOMM DEBUG.
+XCOMM
+#undef DEBUG
+
+XCOMM ----------------------------------------------------------------------
+XCOMM Feature: Debug the parser
+XCOMM If you want debugging output for the configuration file parser,
+XCOMM define DEBUGPARSER
+XCOMM
+#undef DEBUGPARSER
+
+XCOMM ----------------------------------------------------------------------
+XCOMM Feature: Compile with lots and lots of warnings
+XCOMM If you use gcc, and want to build with as much paranoia as possible,
+XCOMM define GCC_PEDANTIC.
+XCOMM Quite honestly, I would recommend for you not to use it for now.
+XCOMM You'll just start running and screaming :-). -- Richard Levitte
+XCOMM
+#undef GCC_PEDANTIC
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e50d8cd99ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Stefan Husmann <stefan.husmann@t-online.de>
+# Contributor: flixie <69one@gmx.net>
+pkgname=ctwm
+pkgver=3.8.2
+pkgrel=1
+pkgdesc="Richard's Tab Window Manager"
+arch=('x86_64' 'i686')
+url='http://ctwm.org/'
+license=('custom:MIT' 'custom:X')
+depends=('glibc' 'libjpeg-turbo' 'libxmu' 'libxpm')
+makedepends=('imake' 'setconf')
+backup=('etc/X11/ctwm/system.ctwmrc')
+source=("http://ctwm.org/dist/$pkgname-$pkgver.tar.xz"
+ "Imakefile.local"
+ "copyright")
+sha256sums=('574d67a8a69f2f1ebaa71aa40cc50667e814f74b51f5db8886e2def6a3e0900f'
+ 'ba8b25071ba0cdf03299dd827296b0fd8a6e549dac6f1ce8d50d9f26afd17041'
+ '5242dcee1ffc736abd3e7022648c51039da7f4d998a2eb1eaee57367816886c1')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ setconf Imakefile CONFDIR /etc/X11/ctwm
+ setconf Imakefile PIXMAPDIR /etc/X11/ctwm/images
+ cp ../Imakefile.local .
+ xmkmf
+}
+
+build() {
+ make -C "$pkgname-$pkgver"
+}
+
+package() {
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install install.man
+ install -Dm644 "copyright" "$pkgdir/usr/share/licenses/ctwm/copyright"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/copyright b/copyright
new file mode 100644
index 000000000000..7030909d2c02
--- /dev/null
+++ b/copyright
@@ -0,0 +1,13 @@
+COPYRIGHT
+
+Portions copyright 1988 Evans & Sutherland Computer Corporation; portions
+copyright 1989 Hewlett-Packard Company and the Massachusetts Institute of
+Technology, See X(1) for a full statement of rights and permissions.
+
+AUTHORS
+
+Tom LaStrange, Solbourne Computer; Jim Fulton, MIT X Consortium;
+Steve Pitschke, Stardent Computer; Keith Packard, MIT X Consortium;
+Dave Sternlicht, MIT X Consortium; Dave Payne, Apple Computer;
+Claude Lecommandeur, Swiss Polytechnical Institute of Lausanne (lecom@sic.epfl.ch);
+Richard Levitte (richard@levitte.org). \ No newline at end of file