summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD16
-rw-r--r--cub.pc2
4 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e07a6a769c1..f800e4f621cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Dec 7 11:51:47 UTC 2017
pkgbase = cub
pkgdesc = A flexible library of cooperative threadblock primitives and other utilities for CUDA kernel programming.
- pkgver = 1.4.1
+ pkgver = 1.7.4
pkgrel = 1
url = http://nvlabs.github.com/cub/
arch = any
- license = New BSD
+ license = custom
optdepends = cuda
- source = https://github.com/NVlabs/cub/archive/1.4.1.zip
+ source = https://github.com/NVlabs/cub/archive/1.7.4.zip
source = cub.pc
- sha256sums = f464eda366e4dfe0c1d9ae2a6bbc22c5804cf131f8a67974c01fae4ae8213e8b
- sha256sums = de2d52cbdb9a81936c7cc519cc5a68c4c62012755c2ab3a07bba158a9d4626c4
+ sha256sums = 20a1a39fd97e5da7f40f5f2e7fd73fd2ea59f9dc4bb8a6c5f228aa543e727e31
+ sha256sums = 5003a9ee6d7dfa32bbdfbd67d2a7cfcc6c1ca54630c85012ec0b18b519d80230
pkgname = cub
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f6b787534c08
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.sw*
+*.log
+*/
+*.zip
+*.pkg*
diff --git a/PKGBUILD b/PKGBUILD
index ad30129d6691..83933c8c010a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,17 @@
-# Maintainer: Benjamin Chretien <chretien at lirmm dot fr>
-
+# Maintainer: Jingbei Li <i@jingbei.li>
+# Contributor: Benjamin Chretien <chretien at lirmm dot fr>
pkgname=cub
-pkgver=1.4.1
+pkgver=1.7.4
pkgrel=1
pkgdesc="A flexible library of cooperative threadblock primitives and other utilities for CUDA kernel programming."
arch=('any')
url='http://nvlabs.github.com/cub/'
-license=('New BSD')
-makedepends=()
+license=('custom')
optdepends=('cuda')
-
source=("https://github.com/NVlabs/cub/archive/${pkgver}.zip"
"cub.pc")
-sha256sums=('f464eda366e4dfe0c1d9ae2a6bbc22c5804cf131f8a67974c01fae4ae8213e8b'
- 'de2d52cbdb9a81936c7cc519cc5a68c4c62012755c2ab3a07bba158a9d4626c4')
+sha256sums=('20a1a39fd97e5da7f40f5f2e7fd73fd2ea59f9dc4bb8a6c5f228aa543e727e31'
+ '5003a9ee6d7dfa32bbdfbd67d2a7cfcc6c1ca54630c85012ec0b18b519d80230')
package() {
cd "${srcdir}/cub-${pkgver}"
@@ -24,4 +22,6 @@ package() {
# Install pkg-config file
install -Dm644 "${srcdir}/cub.pc" "${pkgdir}"/usr/lib/pkgconfig/cub.pc
+
+ install -Dm644 LICENSE.TXT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/cub.pc b/cub.pc
index 396d27ad0009..9f430975fa5e 100644
--- a/cub.pc
+++ b/cub.pc
@@ -1,6 +1,6 @@
Name: cub
Description: A flexible library of cooperative threadblock primitives and other utilities for CUDA kernel programming.
Requires:
-Version: 1.4.1
+Version: 1.7.4
Libs:
Cflags: -I/usr/include/cub