summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
-rw-r--r--cub.pc2
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23ecd87c7e2c..b6d405fc222a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = cub
pkgdesc = A flexible library of cooperative threadblock primitives and other utilities for CUDA kernel programming.
- pkgver = 1.1.1
- pkgrel = 2
+ pkgver = 1.2.2
+ pkgrel = 1
url = http://nvlabs.github.com/cub/
arch = any
license = New BSD
makedepends = git
- source = cub::git+https://github.com/NVlabs/cub.git#branch=1.1.1
+ optdepends = cuda
+ source = cub::git+https://github.com/NVlabs/cub.git#branch=1.2.2
source = cub.pc
sha1sums = SKIP
- sha1sums = e35f7b34520e7b8f540b446da69c71c200a3324c
+ sha1sums = 1da49bb3434a79a7dd7c36620725f60537a01bb1
pkgname = cub
diff --git a/PKGBUILD b/PKGBUILD
index 8ddfc334cc48..acfd77204a97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Benjamin Chretien <chretien at lirmm dot fr>
pkgname=cub
-pkgver=1.1.1
-pkgrel=2
+pkgver=1.2.2
+pkgrel=1
pkgdesc="A flexible library of cooperative threadblock primitives and other utilities for CUDA kernel programming."
arch=('any')
url='http://nvlabs.github.com/cub/'
license=('New BSD')
makedepends=('git')
+optdepends=('cuda')
_dir=${pkgname}
source=("${_dir}"::"git+https://github.com/NVlabs/cub.git"#branch=${pkgver}
"cub.pc")
sha1sums=('SKIP'
- 'e35f7b34520e7b8f540b446da69c71c200a3324c')
+ '1da49bb3434a79a7dd7c36620725f60537a01bb1')
package() {
cd ${srcdir}
diff --git a/cub.pc b/cub.pc
index a684875bc0bc..d2dc2dff6df4 100644
--- a/cub.pc
+++ b/cub.pc
@@ -1,6 +1,6 @@
Name: cub
Description: A flexible library of cooperative threadblock primitives and other utilities for CUDA kernel programming.
Requires:
-Version: 1.1.1
+Version: 1.2.2
Libs:
Cflags: -I/usr/include/cub