summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--cub.pc6
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23ecd87c7e2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cub
+ pkgdesc = A flexible library of cooperative threadblock primitives and other utilities for CUDA kernel programming.
+ pkgver = 1.1.1
+ pkgrel = 2
+ url = http://nvlabs.github.com/cub/
+ arch = any
+ license = New BSD
+ makedepends = git
+ source = cub::git+https://github.com/NVlabs/cub.git#branch=1.1.1
+ source = cub.pc
+ sha1sums = SKIP
+ sha1sums = e35f7b34520e7b8f540b446da69c71c200a3324c
+
+pkgname = cub
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ddfc334cc48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Benjamin Chretien <chretien at lirmm dot fr>
+
+pkgname=cub
+pkgver=1.1.1
+pkgrel=2
+pkgdesc="A flexible library of cooperative threadblock primitives and other utilities for CUDA kernel programming."
+arch=('any')
+url='http://nvlabs.github.com/cub/'
+license=('New BSD')
+makedepends=('git')
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/NVlabs/cub.git"#branch=${pkgver}
+ "cub.pc")
+sha1sums=('SKIP'
+ 'e35f7b34520e7b8f540b446da69c71c200a3324c')
+
+package() {
+ cd ${srcdir}
+
+ # Install headers
+ install -d "${pkgdir}/usr/include/cub"
+ cp -r "${_dir}/cub" "${pkgdir}/usr/include"
+
+ # Install pkg-config file
+ install -Dm644 cub.pc "${pkgdir}"/usr/lib/pkgconfig/cub.pc
+}
diff --git a/cub.pc b/cub.pc
new file mode 100644
index 000000000000..a684875bc0bc
--- /dev/null
+++ b/cub.pc
@@ -0,0 +1,6 @@
+Name: cub
+Description: A flexible library of cooperative threadblock primitives and other utilities for CUDA kernel programming.
+Requires:
+Version: 1.1.1
+Libs:
+Cflags: -I/usr/include/cub