summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..691d35b6cd9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cucumber
+ pkgdesc = CLI note taking app
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://gitlab.com/oktopod11/cucumber
+ arch = any
+ license = GPL3
+ depends = bash
+ depends = sed
+ depends = less
+ source = https://gitlab.com/oktopod11/cucumber/raw/master/archive/cucumber-0.1.tar.gz
+ sha256sums = 602ef5bb0d8b38a5ff2b7d4aed467ebf42c7c25968bf9f70e87eac70408871c0
+
+pkgname = cucumber
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d33d1467acf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Nikola Hadžić <nikola@firemail.cc>
+pkgname="cucumber"
+pkgver=0.1
+pkgrel=1
+epoch=
+pkgdesc="CLI note taking app"
+arch=("any")
+url="https://gitlab.com/oktopod11/cucumber"
+license=("GPL3")
+groups=()
+depends=("bash" "sed" "less")
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+source=("https://gitlab.com/oktopod11/$pkgname/raw/master/archive/$pkgname-$pkgver.tar.gz")
+noextract=()
+sha256sums=("602ef5bb0d8b38a5ff2b7d4aed467ebf42c7c25968bf9f70e87eac70408871c0")
+
+package() {
+ mkdir -vp "$pkgdir/usr/bin/"
+ cp -v "$srcdir/$pkgname/cucumber.sh" "$pkgdir/usr/bin/cucumber"
+}