summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO83
-rw-r--r--PKGBUILD183
-rw-r--r--cups-1.6.2-statedir.patch12
-rw-r--r--cups-no-export-ssllibs.patch12
-rw-r--r--cups-no-gzip-man.patch18
-rw-r--r--cups-systemd-socket.patch49
-rw-r--r--cups.install20
-rw-r--r--cups.logrotate5
-rw-r--r--cups.pam3
-rw-r--r--cups.sysusers2
-rw-r--r--guid.patch42
11 files changed, 429 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..779243bf9128
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,83 @@
+pkgbase = cups-git
+ pkgver = 2.3b7.r92.gca2990c7f
+ pkgrel = 3
+ url = https://www.cups.org/
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = libtiff
+ makedepends = libpng
+ makedepends = acl
+ makedepends = pam
+ makedepends = xdg-utils
+ makedepends = krb5
+ makedepends = gnutls
+ makedepends = bc
+ makedepends = colord
+ makedepends = xinetd
+ makedepends = gzip
+ makedepends = autoconf
+ makedepends = libusb
+ makedepends = dbus
+ makedepends = avahi
+ makedepends = hicolor-icon-theme
+ makedepends = systemd
+ makedepends = inetutils
+ makedepends = libpaper
+ makedepends = valgrind
+ source = git://github.com/apple/cups.git
+ source = cups.logrotate
+ source = cups.pam
+ source = cups.sysusers
+ source = cups-no-export-ssllibs.patch
+ source = cups-no-gzip-man.patch
+ source = cups-1.6.2-statedir.patch
+ source = cups-systemd-socket.patch
+ source = guid.patch
+ sha256sums = SKIP
+ sha256sums = d87fa0f0b5ec677aae34668f260333db17ce303aa1a752cba5f8e72623d9acf9
+ sha256sums = 57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5
+ sha256sums = 06173dfaea37bdd9b39b3e09aba98c34ae7112a2f521db45a688907d8848caa2
+ sha256sums = ff3eb0782af0405f5dafe89e04b1b4ea7a49afc5496860d724343bd04f375832
+ sha256sums = b8fc2e3bc603495f0278410350ea8f0161d9d83719feb64f573b63430cb4800b
+ sha256sums = 23349c96f2f7aeb7d48e3bcd35a969f5d5ac8f55a032b0cfaa0a03d7e37ea9af
+ sha256sums = f909719e2595e016c320afa421cad74ccda285ac59b11749ddac58e707d4330a
+ sha256sums = d4537526c1e075866ae22ad263da000fc2a592d36c26b79a459a1cfdade2bb2d
+
+pkgname = libcups-git
+ pkgdesc = The CUPS Printing System - client libraries and headers (GIT version)
+ depends = gnutls
+ depends = libtiff>=4.0.0
+ depends = libpng>=1.5.7
+ depends = krb5
+ depends = avahi
+ depends = libusb
+ provides = libcups=2.3b7.r92.gca2990c7f
+ conflicts = libcups
+
+pkgname = cups-git
+ pkgdesc = The CUPS Printing System - daemon package (GIT version)
+ install = cups.install
+ depends = acl
+ depends = pam
+ depends = avahi
+ depends = libcups-git
+ depends = cups-filters
+ depends = bc
+ depends = dbus
+ depends = systemd
+ depends = libpaper
+ depends = hicolor-icon-theme
+ optdepends = xdg-utils: xdg .desktop file support
+ optdepends = colord: for ICC color profile support
+ provides = cups
+ conflicts = cups
+ backup = etc/cups/cupsd.conf
+ backup = etc/cups/snmp.conf
+ backup = etc/cups/printers.conf
+ backup = etc/cups/classes.conf
+ backup = etc/cups/cups-files.conf
+ backup = etc/cups/subscriptions.conf
+ backup = etc/logrotate.d/cups
+ backup = etc/pam.d/cups
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb0148f6a95b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,183 @@
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgbase="cups-git"
+_pkgbase=cups
+pkgname=('libcups-git' 'cups-git')
+pkgver=2.3b7.r92.gca2990c7f
+pkgrel=3
+arch=('x86_64')
+license=('GPL')
+url="https://www.cups.org/"
+makedepends=('git' 'libtiff' 'libpng' 'acl' 'pam' 'xdg-utils' 'krb5' 'gnutls'
+ 'bc' 'colord' 'xinetd' 'gzip' 'autoconf' 'libusb' 'dbus'
+ 'avahi' 'hicolor-icon-theme' 'systemd' 'inetutils' 'libpaper' 'valgrind')
+source=(git://github.com/apple/cups.git
+ cups.logrotate
+ cups.pam
+ cups.sysusers
+ # improve build and linking
+ cups-no-export-ssllibs.patch
+ cups-no-gzip-man.patch
+ cups-1.6.2-statedir.patch
+ # bugfixes
+ cups-systemd-socket.patch
+ guid.patch)
+sha256sums=('SKIP'
+ 'd87fa0f0b5ec677aae34668f260333db17ce303aa1a752cba5f8e72623d9acf9'
+ '57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
+ '06173dfaea37bdd9b39b3e09aba98c34ae7112a2f521db45a688907d8848caa2'
+ 'ff3eb0782af0405f5dafe89e04b1b4ea7a49afc5496860d724343bd04f375832'
+ 'b8fc2e3bc603495f0278410350ea8f0161d9d83719feb64f573b63430cb4800b'
+ '23349c96f2f7aeb7d48e3bcd35a969f5d5ac8f55a032b0cfaa0a03d7e37ea9af'
+ 'f909719e2595e016c320afa421cad74ccda285ac59b11749ddac58e707d4330a'
+ 'd4537526c1e075866ae22ad263da000fc2a592d36c26b79a459a1cfdade2bb2d')
+pkgver() {
+ cd "$_pkgbase"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+
+ cd ${_pkgbase}
+
+ # improve build and linking
+ # Do not export SSL libs in cups-config
+ patch -Np1 -i ${srcdir}/cups-no-export-ssllibs.patch
+ # don't zip man pages in make install, let makepkg do that / Fedora
+ patch -Np1 -i ${srcdir}/cups-no-gzip-man.patch
+ # move /var/run -> /run for pid file
+ patch -Np1 -i ${srcdir}/cups-1.6.2-statedir.patch
+
+ # bug fixes
+ # make sure network is up when starting and notify systemd - FC
+ patch -Np1 -i ${srcdir}/cups-systemd-socket.patch
+
+ # FS#56818 - https://github.com/apple/cups/issues/5236
+ patch -Np1 -i ${srcdir}/guid.patch
+
+ # set MaxLogSize to 0 to prevent using cups internal log rotation
+ sed -i -e '5i\ ' conf/cupsd.conf.in
+ sed -i -e '6i# Disable cups internal logging - use logrotate instead' conf/cupsd.conf.in
+ sed -i -e '7iMaxLogSize 0' conf/cupsd.conf.in
+
+ sed -i -e 's/WARNING_OPTIONS="-Werror /WARNING_OPTIONS="/g' config-scripts/cups-compiler.m4
+ # Rebuild configure script for not zipping man-pages.
+ aclocal -I config-scripts
+ autoconf -I config-scripts
+}
+
+build() {
+ cd ${_pkgbase}
+
+ # use fixed cups user (id 209) since systemd adds "lp" group without a fixed id
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --sbindir=/usr/bin \
+ --libdir=/usr/lib \
+ --with-logdir=/var/log/cups \
+ --with-docdir=/usr/share/cups/doc \
+ --with-exe-file-perm=0755 \
+ --with-cups-user=209 \
+ --with-cups-group=209 \
+ --enable-pam=yes \
+ --enable-raw-printing \
+ --enable-dbus=yes \
+ --with-dbusdir=/usr/share/dbus-1 \
+ --enable-ssl=yes \
+ --enable-threads \
+ --enable-avahi\
+ --enable-libpaper \
+ --with-php=/usr/bin/php-cgi \
+ --with-optim="$CFLAGS" #--help
+ make -j1
+}
+
+check() {
+ cd ${_pkgbase}
+ #make -k check || /bin/true
+}
+
+package_libcups-git() {
+pkgdesc="The CUPS Printing System - client libraries and headers (GIT version)"
+depends=('gnutls' 'libtiff>=4.0.0' 'libpng>=1.5.7' 'krb5' 'avahi' 'libusb')
+provides=("libcups=${pkgver}")
+conflicts=('libcups')
+
+ cd ${_pkgbase}
+ make -j1 BUILDROOT=${pkgdir} install-headers install-libs
+ # put this into the libs pkg to make other software find the libs(no pkg-config file included)
+ mkdir -p ${pkgdir}/usr/bin
+ install -m755 ${srcdir}/${_pkgbase}/cups-config ${pkgdir}/usr/bin/cups-config
+}
+
+package_cups-git() {
+pkgdesc="The CUPS Printing System - daemon package (GIT version)"
+install=cups.install
+backup=(etc/cups/cupsd.conf
+ etc/cups/snmp.conf
+ etc/cups/printers.conf
+ etc/cups/classes.conf
+ etc/cups/cups-files.conf
+ etc/cups/subscriptions.conf
+ etc/logrotate.d/cups
+ etc/pam.d/cups)
+depends=('acl' 'pam' 'avahi' "libcups-git" 'cups-filters' 'bc'
+ 'dbus' 'systemd' 'libpaper' 'hicolor-icon-theme')
+optdepends=('xdg-utils: xdg .desktop file support'
+ 'colord: for ICC color profile support')
+provides=("cups")
+conflicts=('cups')
+
+ cd ${_pkgbase}
+ make -j1 BUILDROOT=${pkgdir} install-data install-exec
+
+ # this one we ship in the libcups pkg
+ rm -f ${pkgdir}/usr/bin/cups-config
+
+ # kill the sysv stuff
+ rm -rf ${pkgdir}/etc/rc*.d
+ rm -rf ${pkgdir}/etc/init.d
+ install -D -m644 ../cups.logrotate ${pkgdir}/etc/logrotate.d/cups
+ install -D -m644 ../cups.pam ${pkgdir}/etc/pam.d/cups
+
+ # fix perms on /var/spool and /etc
+ chmod 755 ${pkgdir}/var/spool
+ chmod 755 ${pkgdir}/etc
+
+ # use cups group FS#36769
+ install -Dm644 "$srcdir"/cups.sysusers "${pkgdir}/usr/lib/sysusers.d/$pkgname.conf"
+ sed -i "s:#User 209:User 209:" ${pkgdir}/etc/cups/cups-files.conf{,.default}
+ sed -i "s:#Group 209:Group 209:" ${pkgdir}/etc/cups/cups-files.conf{,.default}
+
+ # install ssl directory where to store the certs, solves some samba issues
+ install -dm700 -g 209 ${pkgdir}/etc/cups/ssl
+ # remove directory from package, it will be recreated at each server start
+ rm -rf ${pkgdir}/run
+
+ # install some more configuration files that will get filled by cupsd
+ touch ${pkgdir}/etc/cups/printers.conf
+ touch ${pkgdir}/etc/cups/classes.conf
+ touch ${pkgdir}/etc/cups/subscriptions.conf
+ chgrp -R 209 ${pkgdir}/etc/cups
+
+ # fix dbus policy location - --with-dbusdir doens't work
+ install -dm755 ${pkgdir}/usr/share/dbus-1/system.d
+ mv ${pkgdir}/etc/dbus-1/system.d/cups.conf ${pkgdir}/usr/share/dbus-1/system.d
+ rm -rf ${pkgdir}/etc/dbus-1
+
+ # fix .desktop file
+ sed -i 's|^Exec=htmlview http://localhost:631/|Exec=xdg-open http://localhost:631/|g' ${pkgdir}/usr/share/applications/cups.desktop
+
+ # compress some driver files, adopted from Fedora
+ find ${pkgdir}/usr/share/cups/model -name "*.ppd" | xargs gzip -n9f
+
+ # remove client.conf man page
+ rm -f ${pkgdir}/usr/share/man/man5/client.conf.5
+
+ # comment out all conversion rules which use any of the removed filters that are now part of cups-filters
+ perl -p -i -e 's:^(.*\s+bannertops\s*)$:#\1:' $pkgdir/usr/share/cups/mime/mime.convs
+
+ # comment out unnecessary PageLogFormat entry
+ sed -i -e 's:PageLogFormat:#PageLogFormat:' $pkgdir/etc/cups/cupsd.conf*
+}
diff --git a/cups-1.6.2-statedir.patch b/cups-1.6.2-statedir.patch
new file mode 100644
index 000000000000..c44ebed07c50
--- /dev/null
+++ b/cups-1.6.2-statedir.patch
@@ -0,0 +1,12 @@
+diff -ruN cups-1.6.2.orig/config-scripts/cups-directories.m4 cups-1.6.2/config-scripts/cups-directories.m4
+--- cups-1.6.2.orig/config-scripts/cups-directories.m4 2012-10-01 03:55:23.000000000 +0200
++++ cups-1.6.2/config-scripts/cups-directories.m4 2013-04-02 00:11:41.000000000 +0200
+@@ -420,7 +420,7 @@
+ ;;
+ *)
+ # All others
+- CUPS_STATEDIR="$localstatedir/run/cups"
++ CUPS_STATEDIR="/run/cups"
+ ;;
+ esac])
+ AC_DEFINE_UNQUOTED(CUPS_STATEDIR, "$CUPS_STATEDIR")
diff --git a/cups-no-export-ssllibs.patch b/cups-no-export-ssllibs.patch
new file mode 100644
index 000000000000..e227bd182390
--- /dev/null
+++ b/cups-no-export-ssllibs.patch
@@ -0,0 +1,12 @@
+diff -up cups-1.5b1/config-scripts/cups-ssl.m4.no-export-ssllibs cups-1.5b1/config-scripts/cups-ssl.m4
+--- cups-1.6.2/config-scripts/cups-ssl.m4.no-export-ssllibs 2011-05-11 02:52:08.000000000 +0200
++++ cups-1.6.2/config-scripts/cups-ssl.m4 2011-05-23 17:47:27.000000000 +0200
+@@ -180,7 +180,7 @@
+ AC_SUBST(SSLFLAGS)
+ AC_SUBST(SSLLIBS)
+
+-EXPORT_SSLLIBS="$SSLLIBS"
++EXPORT_SSLLIBS=""
+ AC_SUBST(EXPORT_SSLLIBS)
+
+ dnl
diff --git a/cups-no-gzip-man.patch b/cups-no-gzip-man.patch
new file mode 100644
index 000000000000..a66971cbc4b7
--- /dev/null
+++ b/cups-no-gzip-man.patch
@@ -0,0 +1,18 @@
+diff -up cups-1.5b1/config-scripts/cups-manpages.m4.no-gzip-man cups-1.5b1/config-scripts/cups-manpages.m4
+--- cups-1.5b1/config-scripts/cups-manpages.m4.no-gzip-man 2011-05-12 07:21:56.000000000 +0200
++++ cups-1.5b1/config-scripts/cups-manpages.m4 2011-05-23 17:25:50.000000000 +0200
+@@ -69,10 +69,10 @@ case "$uname" in
+ ;;
+ Linux* | GNU* | Darwin*)
+ # Linux, GNU Hurd, and macOS
+- MAN1EXT=1.gz
+- MAN5EXT=5.gz
+- MAN7EXT=7.gz
+- MAN8EXT=8.gz
++ MAN1EXT=1
++ MAN5EXT=5
++ MAN7EXT=7
++ MAN8EXT=8
+ MAN8DIR=8
+ ;;
+ *)
diff --git a/cups-systemd-socket.patch b/cups-systemd-socket.patch
new file mode 100644
index 000000000000..3369ceb57ce2
--- /dev/null
+++ b/cups-systemd-socket.patch
@@ -0,0 +1,49 @@
+diff -up cups-2.0.2/scheduler/main.c.ustTJg cups-2.0.2/scheduler/main.c
+--- cups-2.0.2/scheduler/main.c.ustTJg 2015-02-10 13:40:24.121547526 +0100
++++ cups-2.0.2/scheduler/main.c 2015-02-10 13:40:24.295545063 +0100
+@@ -690,8 +690,15 @@ main(int argc, /* I - Number of comm
+
+ #if defined(HAVE_ONDEMAND)
+ if (OnDemand)
++ {
+ cupsdAddEvent(CUPSD_EVENT_SERVER_STARTED, NULL, NULL, "Scheduler started on demand.");
+- else
++# ifdef HAVE_SYSTEMD
++ sd_notifyf(0, "READY=1\n"
++ "STATUS=Scheduler is running...\n"
++ "MAINPID=%lu",
++ (unsigned long) getpid());
++# endif /* HAVE_SYSTEMD */
++ } else
+ #endif /* HAVE_ONDEMAND */
+ if (fg)
+ cupsdAddEvent(CUPSD_EVENT_SERVER_STARTED, NULL, NULL, "Scheduler started in foreground.");
+diff -up cups-2.0.2/scheduler/org.cups.cupsd.path.in.ustTJg cups-2.0.2/scheduler/org.cups.cupsd.path.in
+--- cups-2.0.2/scheduler/org.cups.cupsd.path.in.ustTJg 2014-03-21 15:50:24.000000000 +0100
++++ cups-2.0.2/scheduler/org.cups.cupsd.path.in 2015-02-10 13:40:24.295545063 +0100
+@@ -2,7 +2,7 @@
+ Description=CUPS Scheduler
+
+ [Path]
+-PathExists=@CUPS_CACHEDIR@/org.cups.cupsd
++PathExistsGlob=@CUPS_REQUESTS@/d*
+
+ [Install]
+ WantedBy=multi-user.target
+diff -up cups-2.0.2/scheduler/org.cups.cupsd.service.in.ustTJg cups-2.0.2/scheduler/org.cups.cupsd.service.in
+--- cups-2.0.2/scheduler/org.cups.cupsd.service.in.ustTJg 2014-10-21 13:55:01.000000000 +0200
++++ cups-2.0.2/scheduler/org.cups.cupsd.service.in 2015-02-10 13:40:24.296545049 +0100
+@@ -1,10 +1,11 @@
+ [Unit]
+ Description=CUPS Scheduler
+ Documentation=man:cupsd(8)
++After=network.target
+
+ [Service]
+ ExecStart=@sbindir@/cupsd -l
+-Type=simple
++Type=notify
+ Restart=on-failure
+
+ [Install]
+
diff --git a/cups.install b/cups.install
new file mode 100644
index 000000000000..c83a437ea8c3
--- /dev/null
+++ b/cups.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo ">> If you use an HTTPS connection to CUPS, the first time you access"
+ echo ">> the interface it may take a very long time before the site comes up."
+ echo ">> This is because the first request triggers the generation of the CUPS"
+ echo ">> SSL certificates which can be a very time-consuming job."
+}
+
+post_upgrade() {
+ # FS#56818 - make sure we change the ownership to the new cups group
+ if [[ $(vercmp 2.2.6-3 $2) = 1 ]]; then
+ chgrp -R 209 /etc/cups
+ echo "Cups daemon is now running under \"cups\" user+group."
+ echo "Please make sure to enable the new user+group change in"
+ echo "/etc/cups/cups-files.conf or merge changes from"
+ echo "/etc/cups/cups-files.conf.default. After a service restart"
+ echo "make sure /etc/cups and all files within are owned by"
+ echo "cups group - run \"chgrp -R cups /etc/cups\"."
+ fi
+}
+
diff --git a/cups.logrotate b/cups.logrotate
new file mode 100644
index 000000000000..19e12101be2b
--- /dev/null
+++ b/cups.logrotate
@@ -0,0 +1,5 @@
+/var/log/cups/*_log {
+ missingok
+ notifempty
+ sharedscripts
+}
diff --git a/cups.pam b/cups.pam
new file mode 100644
index 000000000000..53724d1f86a7
--- /dev/null
+++ b/cups.pam
@@ -0,0 +1,3 @@
+auth required pam_unix.so
+account required pam_unix.so
+session required pam_unix.so
diff --git a/cups.sysusers b/cups.sysusers
new file mode 100644
index 000000000000..4ab9d5905968
--- /dev/null
+++ b/cups.sysusers
@@ -0,0 +1,2 @@
+u cups 209 "cups helper user"
+m cups lp
diff --git a/guid.patch b/guid.patch
new file mode 100644
index 000000000000..ce28e024f3fd
--- /dev/null
+++ b/guid.patch
@@ -0,0 +1,42 @@
+diff --git a/scheduler/cups-exec.c b/scheduler/cups-exec.c
+index aab43a797..46c549075 100644
+--- a/scheduler/cups-exec.c
++++ b/scheduler/cups-exec.c
+@@ -133,8 +133,13 @@ main(int argc, /* I - Number of command-line args */
+ if (setgid(gid))
+ exit(errno + 100);
+
+- if (setgroups(1, &gid))
++#include <pwd.h>
++ struct passwd * pwd = getpwuid(uid);
++ if(initgroups(pwd->pw_name,pwd->pw_gid))
++ {
++ fprintf(stderr, "DEBUG: initgroups failed\n");
+ exit(errno + 100);
++ }
+
+ if (uid && setuid(uid))
+ exit(errno + 100);
+diff --git a/scheduler/util.c b/scheduler/util.c
+index 19ebf069b..4638562bd 100644
+--- a/scheduler/util.c
++++ b/scheduler/util.c
+@@ -300,7 +300,16 @@ cupsdPipeCommand(int *pid, /* O - Process ID or 0 on error */
+ */
+
+ if (!getuid() && user)
+- setuid(user); /* Run as restricted user */
++ {
++#include <pwd.h>
++ struct passwd * pwd = getpwuid(user);
++ if(initgroups(pwd->pw_name,pwd->pw_gid))
++ {
++ fprintf(stderr, "DEBUG: initgroups failed\n");
++ exit(errno + 100);
++ }
++ setuid(user); /* Run as restricted user */
++ }
+
+ if ((fd = open("/dev/null", O_RDONLY)) > 0)
+ {
+