summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8eac1674cb6..65f0cd818b8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,26 @@
pkgbase = cura-lulzbot
pkgdesc = Cura LulzBot Edition for LulzBot 3D Printers by Aleph Objects, Inc.
pkgver = 3.6.21
- pkgrel = 6
+ pkgrel = 8
url = https://www.lulzbot.com/cura
arch = x86_64
license = AGPL3
makedepends = cmake
makedepends = git
- makedepends = python-sip
+ makedepends = python-pip
makedepends = python-netifaces
makedepends = python-pyserial
+ makedepends = python-sip
makedepends = python-zeroconf
makedepends = qt5-tools
- makedepends = sip
+ makedepends = sip4
depends = cython
depends = gcc-fortran
depends = libffi6
depends = libsavitar
+ depends = libxcrypt-compat
depends = openblas
depends = python
- depends = python-cx_freeze
depends = python-nose
depends = python-numpy
depends = python-numpy-stl
@@ -40,4 +41,3 @@ pkgbase = cura-lulzbot
md5sums = SKIP
pkgname = cura-lulzbot
-
diff --git a/PKGBUILD b/PKGBUILD
index b4ff97013835..f94a79488c56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# https://gitlab.com/lulzbot3d/cura-le/curabuild-lulzbot/
pkgname=cura-lulzbot
pkgver=3.6.21
-pkgrel=6
+pkgrel=8
pkgdesc='Cura LulzBot Edition for LulzBot 3D Printers by Aleph Objects, Inc.'
arch=('x86_64')
url='https://www.lulzbot.com/cura'
@@ -14,9 +14,9 @@ depends=('cython'
'gcc-fortran'
'libffi6'
'libsavitar'
+ 'libxcrypt-compat'
'openblas'
'python'
- 'python-cx_freeze'
'python-nose'
'python-numpy'
'python-numpy-stl'
@@ -32,12 +32,13 @@ depends=('cython'
'qt5-svg')
makedepends=('cmake'
'git'
- 'python-sip'
+ 'python-pip'
'python-netifaces'
'python-pyserial'
+ 'python-sip'
'python-zeroconf'
'qt5-tools'
- 'sip')
+ 'sip4')
optdepends=('python-zeroconf: Detecting mDNS printers'
'python-pyserial: USB printing')
@@ -59,6 +60,12 @@ build() {
sed -i 's/DCURA_ENGINE_VERSION=${CURA_VERSION}/DCURA_ENGINE_VERSION=${CURA_VERSION} -DENABLE_OPENMP=OFF/' ../CMakeLists.txt
sed -i '33,34 s/^/#pkgbuild /' ../setup_linux.py.in # Disable missing paths from using system python
sed -i '57,60 s/^/#pkgbuild /' ../setup_linux.py.in # Disable missing qt plugins when using system version
+
+ # Use an older version of cx_freeze to address
+ # TypeError: $ expected str, bytes or os.PathLike object, not NoneType
+ # https://github.com/marcelotduarte/cx_Freeze/issues/730
+ pip install --user cx_freeze==6.0
+
sed -i 's/get_commit_hash("Savitar", cmake_binary_dir)/"4.1.0"/' ../scripts/cura_version.py # Fake hash when using system libsavitar
sed -i 's/6a4ffb2f90ef7bbd3f20f2a1db4948630ad37dc8/v3.11.0/' ../CMakeLists.txt # Protobuf v3.7.0
@@ -105,6 +112,9 @@ package() {
PYTHONPATH=`pwd`/inst/lib/python3/dist-packages make package
cp -r _CPack_Packages/Linux/DEB/cura-lulzbot-*-Linux/usr $pkgdir/
+
+ cp -r `pwd`/inst/share/cura/resources $pkgdir/usr/share/cura-lulzbot/
+ cp -r `pwd`/inst/share/uranium/resources $pkgdir/usr/share/cura-lulzbot/
}
# Update md5sum
@@ -121,4 +131,4 @@ package() {
# We also need to manually install openblas to avoid a conflict with blas.
#
# Ex.
-# extra-x86_64-build -- -c -I ~/builds/libffi6/libffi6-3.2.1-1-x86_64.pkg.tar.xz -I ~/builds/python-numpy-stl/python-numpy-stl-2.10.1-1-any.pkg.tar.xz -I /var/cache/pacman/pkg/openblas-0.3.10-1-x86_64.pkg.tar.zst
+# extra-x86_64-build -- -c -I ~/builds/libffi6/libffi6-3.2.1-1-x86_64.pkg.tar.zst -I ~/builds/python-numpy-stl/python-numpy-stl-2.16.3-1-x86_64.pkg.tar.zst -I /var/cache/pacman/pkg/openblas-0.3.18-1-x86_64.pkg.tar.zst