summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5877d12d5b2d..6187ec7e06ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
# Maintainer: Kevin McCormack <harlemsquirrel@gmail.com>
# https://code.alephobjects.com/w/cura-lulzbot/
pkgname=cura-lulzbot
-pkgver=3.6.13
+pkgver=3.6.18
pkgrel=1
pkgdesc='Cura LulzBot Edition for LulzBot 3D Printers by Aleph Objects, Inc.'
arch=('x86_64')
url='https://www.lulzbot.com/cura'
license=('AGPLv3')
-source=("http://download.alephobjects.com/ao/aodeb/dists/stretch/main/binary-amd64/cura-lulzbot_${pkgver}_amd64.deb")
-md5sums=('a94bfe8f2ae018acda9c6fdec4fff322')
-depends=('gcc6-fortran')
+source=("http://download.alephobjects.com/ao/aodeb/dists/buster/main/binary-amd64/cura-lulzbot_${pkgver}_amd64.deb")
+md5sums=('54b1a5fed4804fb09a481bf868d6ad08')
+depends=('gcc8-fortran' 'openssl-1.0')
prepare() {
# Unpack the tarball containing the 'usr/' directory,
# where all the essentials reside within the debian package
tar zxf "${srcdir}/data.tar".gz -C "${srcdir}"
- fortran_lib_dir=`dirname $(find /usr/lib/gcc/x86_64-pc-linux-gnu/6* -name libgfortran.so.3 -print -quit)`
- sed -i "s;LD_LIBRARY_PATH=;LD_LIBRARY_PATH=${fortran_lib_dir}:;" "${srcdir}/usr/bin/cura-lulzbot"
}
package() {