summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7056c354ca6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = customizepkg-scripting
+ pkgdesc = A tool to modify automatically PKGBUILDs - modified to just run scripts
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/Scimmia22/customizepkg-scripting
+ arch = any
+ license = GPL
+ depends = bash
+ depends = diffutils
+ optdepends = vim: for vimdiff
+ provides = customizepkg
+ conflicts = customizepkg
+ source = https://github.com/Scimmia22/customizepkg-scripting/archive/0.3.0.tar.gz
+ sha256sums = 4bb8c7caef6b885d5edd605a04dcc81c88a7232c79cf1d379980bae58fc9401c
+
+pkgname = customizepkg-scripting
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1561e82616a2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*/
+*~
+*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90d75b4b989e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Doug Newgard <scimmia22 at outlook dot com>
+# Contributor: wain <wain.at.archlinux.fr>
+
+pkgname=customizepkg-scripting
+_pkgname=customizepkg
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="A tool to modify automatically PKGBUILDs - modified to just run scripts"
+url="https://github.com/Scimmia22/customizepkg-scripting"
+license="GPL"
+arch=('any')
+depends=('bash' 'diffutils')
+optdepends=('vim: for vimdiff')
+provides=('customizepkg')
+conflicts=('customizepkg')
+source=("https://github.com/Scimmia22/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('4bb8c7caef6b885d5edd605a04dcc81c88a7232c79cf1d379980bae58fc9401c')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm755 customizepkg "$pkgdir/usr/bin/customizepkg"
+ install -Dm644 instructions "$pkgdir/etc/customizepkg.d/instructions"
+}
+