summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e23d5a5dc255..145dbc381a79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = cutegram
pkgdesc = A different telegram client from Aseman team
pkgver = 2.5.0
- pkgrel = 1
+ pkgrel = 2
url = http://aseman.co/en/products/cutegram/
arch = i686
arch = x86_64
license = GPL
depends = qt5-imageformats
- depends = gstreamer0.10-base-plugins
- depends = gstreamer0.10-good-plugins
+ depends = qt5-webkit>=5.5
depends = telegramqml
- depends = libqtelegram-ae>=2:0.5.0
+ depends = libqtelegram-ae>=2:5.0
+ optdepends = gst-plugins-bad: audio support
+ optdepends = gst-plugins-good: audio and notification sound
provides = cutegram
conflicts = cutegram-git
conflicts = sigram-git
diff --git a/PKGBUILD b/PKGBUILD
index 33287bf86ff4..951d02eab7c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,14 @@
pkgname=cutegram
_pkgname=Cutegram
pkgver=2.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="A different telegram client from Aseman team"
arch=('i686' 'x86_64')
url="http://aseman.co/en/products/cutegram/"
license=('GPL')
-depends=('qt5-imageformats' 'gstreamer0.10-base-plugins' 'gstreamer0.10-good-plugins'
-'telegramqml' 'libqtelegram-ae>=2:0.5.0')
+depends=('qt5-imageformats' 'qt5-webkit>=5.5' 'telegramqml' 'libqtelegram-ae>=2:5.0')
+optdepends=('gst-plugins-bad: audio support'
+'gst-plugins-good: audio and notification sound')
conflicts=('cutegram-git' 'sigram-git' 'sigram' 'cutegram')
provides=('cutegram')
replaces=('cutegram-cn')
@@ -25,12 +26,12 @@ sha256sums=('c92d7dc1f03e50ec7245c5f16e34e1780af9a171eeba7f91763bd92d45a7da4a')
prepare() {
cd "${srcdir}/${_pkgname}-$pkgver-stable"
- mkdir -p build
+ mkdir -p build
}
build() {
cd "${srcdir}/${_pkgname}-$pkgver-stable/build"
- qmake-qt5 -r .. PREFIX=/usr DEFINES+=WEBENGINE_ASEMAN_WEBGRABBER
+ qmake-qt5 -r .. PREFIX=/usr
make
}