summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--remove-ubuntu_almost_fixed_height_mode.patch11
3 files changed, 21 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b06948a9782f..4f82751d6041 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cuttlefish
pkgdesc = Adapt your computer's appearance and settings according to the environment.
pkgver = 12.08
- pkgrel = 6
+ pkgrel = 7
url = https://launchpad.net/cuttlefish
install = cuttlefish.install
arch = any
@@ -18,15 +18,11 @@ pkgbase = cuttlefish
source = https://launchpad.net/cuttlefish/trunk/12.08/+download/cuttlefish_12.08.tar.gz
source = plugins-use-site-packages.patch
source = desktop-autostart.patch
- md5sums = 400e8caa17036c1aa5a0fda570241c05
- md5sums = 3379bb17d3e36e37b9bc7ea3d2fb0e0c
- md5sums = ed2b506ac114bab485b71d664fdcfdd3
- sha1sums = 58372fdc4a91a5a3fd8aa4a933460a46a72a8bb7
- sha1sums = 8033ec7c0e5fabdbad6f8364e52cf60499e0f5ab
- sha1sums = e17e6ec055a9dd676596dd4bd61d48adbc2ca98a
+ source = remove-ubuntu_almost_fixed_height_mode.patch
sha256sums = e53702fe841ddddaa74a7b02dca7d6edf1fd314ccac831bfd6d1b235ed4c57b0
sha256sums = 3d6e2db4d085fd014ffcb5cee22ab2125bc1f77c7cb4cb50aa8e06fcd195ef3c
sha256sums = d764d78d59a5789f422eed77fd6b34b1bdc981d4e0c5afa0148b2e16ee276c39
+ sha256sums = 30d17a770792016d07c9a695376bddca17c201143b2e2e04aa30f3b83d90905b
pkgname = cuttlefish
diff --git a/PKGBUILD b/PKGBUILD
index bfd93ae93b49..d29bfd750341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cuttlefish
pkgver=12.08
-pkgrel=6
+pkgrel=7
pkgdesc="Adapt your computer's appearance and settings according to the environment."
arch=('any')
url="https://launchpad.net/cuttlefish"
@@ -10,21 +10,18 @@ license=('GPL')
depends=('python2' 'python2-distutils-extra' 'python2-psutil' 'python2-udev' 'python2-gobject' 'python2-xdg' 'gnome-menus' 'libwnck3' 'dconf')
install='cuttlefish.install'
source=("https://launchpad.net/cuttlefish/trunk/${pkgver}/+download/cuttlefish_${pkgver}.tar.gz"
- 'plugins-use-site-packages.patch'
- 'desktop-autostart.patch')
-md5sums=('400e8caa17036c1aa5a0fda570241c05'
- '3379bb17d3e36e37b9bc7ea3d2fb0e0c'
- 'ed2b506ac114bab485b71d664fdcfdd3')
-sha1sums=('58372fdc4a91a5a3fd8aa4a933460a46a72a8bb7'
- '8033ec7c0e5fabdbad6f8364e52cf60499e0f5ab'
- 'e17e6ec055a9dd676596dd4bd61d48adbc2ca98a')
+ "plugins-use-site-packages.patch"
+ "desktop-autostart.patch"
+ "remove-ubuntu_almost_fixed_height_mode.patch")
sha256sums=('e53702fe841ddddaa74a7b02dca7d6edf1fd314ccac831bfd6d1b235ed4c57b0'
'3d6e2db4d085fd014ffcb5cee22ab2125bc1f77c7cb4cb50aa8e06fcd195ef3c'
- 'd764d78d59a5789f422eed77fd6b34b1bdc981d4e0c5afa0148b2e16ee276c39')
+ 'd764d78d59a5789f422eed77fd6b34b1bdc981d4e0c5afa0148b2e16ee276c39'
+ '30d17a770792016d07c9a695376bddca17c201143b2e2e04aa30f3b83d90905b')
prepare() {
patch -p0 -i "plugins-use-site-packages.patch"
patch -p0 -i "desktop-autostart.patch"
+ patch -p0 -i "remove-ubuntu_almost_fixed_height_mode.patch"
}
package() {
diff --git a/remove-ubuntu_almost_fixed_height_mode.patch b/remove-ubuntu_almost_fixed_height_mode.patch
new file mode 100644
index 000000000000..fddfc23028db
--- /dev/null
+++ b/remove-ubuntu_almost_fixed_height_mode.patch
@@ -0,0 +1,11 @@
+diff -Naur cuttlefish.orig/data/ui/CuttlefishWindow.ui cuttlefish/data/ui/CuttlefishWindow.ui
+--- cuttlefish.orig/data/ui/CuttlefishWindow.ui 2012-07-30 01:59:11.000000000 +0200
++++ cuttlefish/data/ui/CuttlefishWindow.ui 2015-06-13 20:54:31.750518028 +0200
+@@ -606,7 +606,6 @@
+ <property name="can_focus">True</property>
+ <property name="headers_clickable">False</property>
+ <property name="search_column">0</property>
+- <property name="ubuntu_almost_fixed_height_mode">True</property>
+ <signal name="cursor-changed" handler="on_tvActions_cursor_changed" swapped="no"/>
+ <child internal-child="selection">
+ <object class="GtkTreeSelection" id="treeview-selection1"/>