summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD44
-rw-r--r--cuttlefish-bzr.install7
-rw-r--r--desktop-autostart.patch19
-rw-r--r--plugins-use-site-packages.patch12
5 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2f77f3509f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = cuttlefish-bzr
+ pkgdesc = Adapt your computer's appearance and settings according to the environment.
+ pkgver = 76
+ pkgrel = 5
+ url = https://launchpad.net/cuttlefish
+ install = cuttlefish-bzr.install
+ arch = any
+ license = GPL
+ makedepends = bzr
+ depends = python2
+ depends = python2-distutils-extra
+ depends = python2-psutil
+ depends = python2-udev
+ depends = gnome-menus
+ depends = libwnck3
+ source = cuttlefish::bzr+https://code.launchpad.net/~noneed4anick/cuttlefish/trunk
+ source = plugins-use-site-packages.patch
+ source = desktop-autostart.patch
+ md5sums = SKIP
+ md5sums = 7c631a9a83197b4d2ae5274d53b5ec73
+ md5sums = b555d227e909a61788a4d2c8acd3120d
+ sha1sums = SKIP
+ sha1sums = 43cd8935b8db879fb383164358d0dcd1d59cfd69
+ sha1sums = 3498c050110cb84fe36706c627ac232652afb4b3
+ sha256sums = SKIP
+ sha256sums = e7cf831a5083655a29a765626a765fe44069b05c31f5749ca76f6d9f22160480
+ sha256sums = 26a91ab2ff6c21f8f3e8eb3474396ec8940313f158778b1fd8711f2643357a5d
+
+pkgname = cuttlefish-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b27418e52bbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Muflone <webreg@vbsimple.net>
+# Contributor: Ryon Sherman <ryon.sherman@gmail.com>
+
+pkgname=cuttlefish-bzr
+_pkgname=cuttlefish
+pkgver=76
+pkgrel=5
+pkgdesc="Adapt your computer's appearance and settings according to the environment."
+arch=('any')
+url="https://launchpad.net/cuttlefish"
+license=('GPL')
+depends=('python2' 'python2-distutils-extra' 'python2-psutil' 'python2-udev' 'gnome-menus' 'libwnck3')
+makedepends=('bzr')
+install="${pkgname}.install"
+source=("${_pkgname}"::"bzr+https://code.launchpad.net/~noneed4anick/cuttlefish/trunk"
+ "plugins-use-site-packages.patch"
+ "desktop-autostart.patch"
+ )
+md5sums=('SKIP'
+ '7c631a9a83197b4d2ae5274d53b5ec73'
+ 'b555d227e909a61788a4d2c8acd3120d')
+sha1sums=('SKIP'
+ '43cd8935b8db879fb383164358d0dcd1d59cfd69'
+ '3498c050110cb84fe36706c627ac232652afb4b3')
+sha256sums=('SKIP'
+ 'e7cf831a5083655a29a765626a765fe44069b05c31f5749ca76f6d9f22160480'
+ '26a91ab2ff6c21f8f3e8eb3474396ec8940313f158778b1fd8711f2643357a5d')
+
+pkgver() {
+ cd "${_pkgname}"
+ bzr revno
+}
+
+prepare() {
+ cd "${_pkgname}"
+ patch -p1 -i "../plugins-use-site-packages.patch"
+ patch -p1 -i "../desktop-autostart.patch"
+}
+
+package() {
+ cd "${_pkgname}"
+ glib-compile-schemas "data/glib-2.0/schemas"
+ GSETTINGS_SCHEMA_DIR="data/glib-2.0/schemas" python2 setup.py install --root="${pkgdir}/" --optimize=1
+}
diff --git a/cuttlefish-bzr.install b/cuttlefish-bzr.install
new file mode 100644
index 000000000000..eb1c0d4292bc
--- /dev/null
+++ b/cuttlefish-bzr.install
@@ -0,0 +1,7 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
+post_remove() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
diff --git a/desktop-autostart.patch b/desktop-autostart.patch
new file mode 100644
index 000000000000..2893466bf084
--- /dev/null
+++ b/desktop-autostart.patch
@@ -0,0 +1,19 @@
+diff -aur cuttlefish.orig/cuttlefish/PreferencesCuttlefishDialog.py cuttlefish-build/cuttlefish/PreferencesCuttlefishDialog.py
+--- cuttlefish.orig/cuttlefish/PreferencesCuttlefishDialog.py 2012-10-06 15:20:01.000000000 +0200
++++ cuttlefish-build/cuttlefish/PreferencesCuttlefishDialog.py 2012-10-06 15:22:07.939424977 +0200
+@@ -70,13 +70,13 @@
+ else:
+ self._autostart.add_section('Desktop Entry', )
+ self._autostart.set('Desktop Entry', 'Type', 'Application')
+- self._autostart.set('Desktop Entry', 'Exec', '/opt/extras.ubuntu.com/cuttlefish/bin/cuttlefish --hidden')
++ self._autostart.set('Desktop Entry', 'Exec', '/usr/bin/cuttlefish --hidden')
+ self._autostart.set('Desktop Entry', 'Hidden', 'false')
+ self._autostart.set('Desktop Entry', 'NoDisplay', 'false')
+ self._autostart.set('Desktop Entry', 'X-GNOME-Autostart-enabled', 'false')
+ self._autostart.set('Desktop Entry', 'Name', 'Cuttlefish')
+ self._autostart.set('Desktop Entry', 'Categories', 'GNOME;Utility;')
+- self._autostart.set('Desktop Entry', 'Icon', '/opt/extras.ubuntu.com/cuttlefish/share/cuttlefish/media/tentacle.svg')
++ self._autostart.set('Desktop Entry', 'Icon', '/usr/share/cuttlefish/media/tentacle.svg')
+ self._autostart.set('Desktop Entry', 'Comment', 'Cuttlefish Autostart Entry')
+
+ self.ui.togAutostart.set_active(self._autostart.getboolean('Desktop Entry', 'X-GNOME-Autostart-enabled'))
diff --git a/plugins-use-site-packages.patch b/plugins-use-site-packages.patch
new file mode 100644
index 000000000000..9669229f973e
--- /dev/null
+++ b/plugins-use-site-packages.patch
@@ -0,0 +1,12 @@
+diff -aur cuttlefish.orig/cuttlefish/plugins/__init__.py cuttlefish-build/cuttlefish/plugins/__init__.py
+--- cuttlefish.orig/cuttlefish/plugins/__init__.py 2012-09-04 19:52:07.478273399 +0000
++++ cuttlefish-build/cuttlefish/plugins/__init__.py 2012-09-04 19:52:39.641606500 +0000
+@@ -50,7 +50,7 @@
+
+ self.__add_dir('cuttlefish.plugins.user', '~/.cuttlefish/plugins')
+ self.__add_dir('cuttlefish.plugins.default', '/opt/extras.ubuntu.com/cuttlefish/cuttlefish/plugins')
+- self.__add_dir('cuttlefish.plugins.altdefault', '/usr/lib/python2.7/dist-packages/cuttlefish/plugins')
++ self.__add_dir('cuttlefish.plugins.altdefault', '/usr/lib/python2.7/site-packages/cuttlefish/plugins')
+
+ def __add_dir(self, modid, dir):
+ dir = os.path.abspath(os.path.expandvars(os.path.expanduser(dir)))