summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
-rw-r--r--cwiid.install3
4 files changed, 26 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef8029a20d2b..c45d5c445603 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = cwiid
pkgdesc = Linux Nintendo Wiimote interface
pkgver = svn_history
- pkgrel = 2
- url = http://abstrakraft.org/cwiid
+ pkgrel = 3
+ url = https://github.com/abstrakraft/cwiid
install = cwiid.install
arch = x86_64
- license = GPL
+ license = GPL2
depends = bluez-libs
depends = gtk2
depends = python2
- source = https://github.com/abstrakraft/cwiid/archive/svn_history.tar.gz
- sha512sums = 25c105c37ae0778b6e47c4a02bfc74380f3b3dcc4cb71a3968a243a7de33c55d8b6d7860d826d1d5a6a197223fdb6022effd27d40394ca7007d997694438739b
+ source = cwiid-svn_history.tar.gz::https://github.com/abstrakraft/cwiid/archive/svn_history.tar.gz
+ sha256sums = 31d3e843c107f07e2b425bee17dafa215937c582b3b4d9c7bc71f4edcfe5ea68
pkgname = cwiid
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a15dab405ffb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+cwiid-*.pkg.tar.xz
+cwiid-*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 08529b69d70f..0d68b195a42b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,40 +10,42 @@
pkgname=cwiid
pkgver=svn_history
-pkgrel=2
+pkgrel=3
pkgdesc="Linux Nintendo Wiimote interface"
arch=("x86_64")
-url="http://abstrakraft.org/${pkgname}"
+url="https://github.com/abstrakraft/${pkgname}"
depends=("bluez-libs" "gtk2" "python2")
-license=("GPL")
+license=("GPL2")
install="${pkgname}.install"
-source=("https://github.com/abstrakraft/${pkgname}/archive/${pkgver}.tar.gz")
-sha512sums=("25c105c37ae0778b6e47c4a02bfc74380f3b3dcc4cb71a3968a243a7de33c55d8b6d7860d826d1d5a6a197223fdb6022effd27d40394ca7007d997694438739b")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/abstrakraft/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('31d3e843c107f07e2b425bee17dafa215937c582b3b4d9c7bc71f4edcfe5ea68')
-#cwiid-0.6.00 trunk@201 svn_history
+#cwiid-0.6.00 trunk@201 918edb2d-ff29-0410-9de2-eb38e7f22bc7
+#svn_history-0-g3163ded
prepare() {
- cd "${pkgname}-${pkgver}"
- # fixing ldconfig use in configure
- sed -i "/ldconfig/s/WITH/ENABLE/" configure.ac
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ msg2 "Fixing ldconfig use in configure"
+ sed -i "/ldconfig/s/WITH/ENABLE/" "${srcdir}/${pkgname}-${pkgver}/configure.ac"
autoreconf -fi
}
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--with-python=python2 \
--enable-ldconfig=no
-
LDFLAGS+=" -pthread -lpthread -lbluetooth" make
}
package() {
- cd "${pkgname}-${pkgver}"
+ msg2 "Installing application"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- # wminput README
- install -Dm644 wminput/README "${pkgdir}/usr/share/doc/${pkgname}/wminput/README"
+ msg2 "Installing wminput README"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/wminput/README" "${pkgdir}/usr/share/doc/${pkgname}/wminput/README"
}
diff --git a/cwiid.install b/cwiid.install
index 10c2c621f8cf..dfbed5b9d8aa 100644
--- a/cwiid.install
+++ b/cwiid.install
@@ -1,6 +1,5 @@
post_install() {
- echo "==> In order to use wminput ensure you load the uinput kernel"
- echo "==> module and have assigned correct access to /dev/uinput"
+ printf "$(tput setaf 4)In order to use wminput ensure you load the uinput kernel module and have assigned correct access to /dev/uinput$(tput sgr0)\n"
}
post_upgrade() {