summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD37
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e00c002e0ac..239c776254c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cwiid
pkgdesc = Linux Nintendo Wiimote interface
- pkgver = 0.6.00+svn201
- pkgrel = 3
+ pkgver = svn_history
+ pkgrel = 1
url = http://abstrakraft.org/cwiid
install = cwiid.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index f7635ad6365c..a0c526d61291 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 271927 2017-12-02 20:55:03Z dvzrv $
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
# Maintainer: David Runge <dave@sleepmap.de>
# Contributor: speps <speps at aur dot archlinux dot org>
# Contributor: Ray Rashif <schiv@archlinux.org>
@@ -9,42 +9,43 @@
# 2012/03/21: <dropped from community; broken + see bug #28344>
pkgname=cwiid
-pkgver=0.6.00+svn201
-pkgrel=3
+pkgver=svn_history
+pkgrel=1
pkgdesc="Linux Nintendo Wiimote interface"
arch=('x86_64')
-url="http://abstrakraft.org/cwiid"
+url="http://abstrakraft.org/${pkgname}"
depends=('bluez-libs' 'gtk2' 'python2')
license=('GPL')
-install="$pkgname.install"
-source=("https://github.com/abstrakraft/cwiid/archive/svn_history.tar.gz")
+install="${pkgname}.install"
+source=("https://github.com/abstrakraft/${pkgname}/archive/${pkgver}.tar.gz")
sha512sums=('25c105c37ae0778b6e47c4a02bfc74380f3b3dcc4cb71a3968a243a7de33c55d8b6d7860d826d1d5a6a197223fdb6022effd27d40394ca7007d997694438739b')
+#cwiid-0.6.00 trunk@201 svn_history
+
prepare() {
- cd "${pkgname}-svn_history"
+ cd "${pkgname}-${pkgver}"
# fixing ldconfig use in configure
sed -i '/ldconfig/s/WITH/ENABLE/' configure.ac
autoreconf -fi
}
build() {
- cd "${pkgname}-svn_history"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --with-python=python2 \
- --enable-ldconfig=no
-
- LDFLAGS+=" -pthread -lpthread -lbluetooth" \
- make
+ cd "${pkgname}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-python=python2 \
+ --enable-ldconfig=no
+
+ LDFLAGS+=" -pthread -lpthread -lbluetooth" make
}
package() {
- cd "${pkgname}-svn_history"
+ cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
# wminput README
- install -Dm644 wminput/README \
- "${pkgdir}/usr/share/doc/${pkgname}/wminput/README"
+ install -Dm644 wminput/README "${pkgdir}/usr/share/doc/${pkgname}/wminput/README"
}
# vim:set ts=2 sw=2 et: