summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a2ae668bf77..40cfec88f59c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cxx-common
pkgdesc = Common dependency management for various Trail of Bits C++ codebases
pkgver = 0.1.1
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/trailofbits/cxx-common
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 4a61a5b81eb8..3c73cb87e652 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cxx-common
pkgver=0.1.1
-pkgrel=6
+pkgrel=7
pkgdesc="Common dependency management for various Trail of Bits C++ codebases"
arch=('x86_64')
url="https://github.com/trailofbits/cxx-common"
@@ -34,6 +34,10 @@ package() {
--overlay-ports=./ports --overlay-triplets=./triplets --raw \
--output="$pkgdir/opt/$pkgname"
+ ## fix prefix paths
+ find $pkgdir/opt/$pkgname/installed/x64-linux-rel/lib/pkgconfig/ -type f \
+ -exec sed -i -e "s,$srcdir/$pkgname-$pkgver/vcpkg/packages/[^ ]*_x64-linux-rel,/opt/$pkgname/installed/x64-linux-rel,g" {} +
+
## install lit
pushd "$srcdir/$pkgname-$pkgver"/vcpkg/buildtrees/llvm-10/src/org-*/llvm/utils/lit
python3 setup.py install --root="$pkgdir" -O1