summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e34d956ee7ba..6a2ae668bf77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cxx-common
pkgdesc = Common dependency management for various Trail of Bits C++ codebases
pkgver = 0.1.1
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/trailofbits/cxx-common
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 19d2b33a2888..4a61a5b81eb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cxx-common
pkgver=0.1.1
-pkgrel=5
+pkgrel=6
pkgdesc="Common dependency management for various Trail of Bits C++ codebases"
arch=('x86_64')
url="https://github.com/trailofbits/cxx-common"
@@ -33,6 +33,11 @@ package() {
./vcpkg/vcpkg export --x-all-installed \
--overlay-ports=./ports --overlay-triplets=./triplets --raw \
--output="$pkgdir/opt/$pkgname"
+
+ ## install lit
+ pushd "$srcdir/$pkgname-$pkgver"/vcpkg/buildtrees/llvm-10/src/org-*/llvm/utils/lit
+ python3 setup.py install --root="$pkgdir" -O1
+ popd
}
# vim: set sw=4 ts=4 et: