summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1796888c23ac..4701c1099a48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cxx-common
pkgdesc = Common dependency management for various Trail of Bits C++ codebases
pkgver = 0.0.14
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/trailofbits/cxx-common
arch = x86_64
license = Apache
@@ -10,8 +10,8 @@ pkgbase = cxx-common
depends = zlib
options = staticlibs
options = !strip
- source = https://github.com/trailofbits/cxx-common/releases/download/v0.0.14/libraries-llvm1100-ubuntu20.04-amd64.tar.xz
- sha256sums = 7a680ea1185dfb83bc8a2c3bdb7930e5c1dfc7d78e3af16da65ca525e82ade39
+ source = https://github.com/trailofbits/cxx-common/releases/download/v0.0.14/libraries-llvm1000-ubuntu20.04-amd64.tar.xz
+ sha256sums = 1d6f576978b7aa4ab52133d3ee587e2c2b84893aa5b77c2f869be00113d31acd
pkgname = cxx-common
diff --git a/PKGBUILD b/PKGBUILD
index 38f23f8e237a..7b4f04d13aae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
pkgname=cxx-common
pkgver=0.0.14
-pkgrel=2
+pkgrel=3
+_LLVMver=1000 # 10.0.0
pkgdesc="Common dependency management for various Trail of Bits C++ codebases"
arch=('x86_64')
url="https://github.com/trailofbits/cxx-common"
@@ -11,8 +12,8 @@ depends=('openssl' 'ncurses' 'zlib')
makedepends=()
checkdepends=()
options=('staticlibs' '!strip')
-source=("https://github.com/trailofbits/cxx-common/releases/download/v${pkgver}/libraries-llvm1100-ubuntu20.04-amd64.tar.xz")
-sha256sums=('7a680ea1185dfb83bc8a2c3bdb7930e5c1dfc7d78e3af16da65ca525e82ade39')
+source=("https://github.com/trailofbits/cxx-common/releases/download/v${pkgver}/libraries-llvm${_LLVMver}-ubuntu20.04-amd64.tar.xz")
+sha256sums=('1d6f576978b7aa4ab52133d3ee587e2c2b84893aa5b77c2f869be00113d31acd')
package() {
install -dm 755 "$pkgdir/opt/$pkgname"