summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 11 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27fafee6676d..1796888c23ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,17 @@
pkgbase = cxx-common
pkgdesc = Common dependency management for various Trail of Bits C++ codebases
pkgver = 0.0.14
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/trailofbits/cxx-common
arch = x86_64
license = Apache
- makedepends = cmake
- makedepends = python
- makedepends = llvm=11.0.0
- makedepends = clang=11.0.0
- makedepends = ninja
depends = openssl
depends = ncurses
- depends = libxml2
depends = zlib
- source = https://github.com/trailofbits/cxx-common/archive/v0.0.14.tar.gz
- sha256sums = 1f7c3de3fa491cfba52abd4ae5fe5cc00112309239737b89ecc8c00a9b6cb2c2
+ options = staticlibs
+ options = !strip
+ source = https://github.com/trailofbits/cxx-common/releases/download/v0.0.14/libraries-llvm1100-ubuntu20.04-amd64.tar.xz
+ sha256sums = 7a680ea1185dfb83bc8a2c3bdb7930e5c1dfc7d78e3af16da65ca525e82ade39
pkgname = cxx-common
diff --git a/PKGBUILD b/PKGBUILD
index cca3efa664cf..38f23f8e237a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,21 @@
pkgname=cxx-common
pkgver=0.0.14
-pkgrel=1
+pkgrel=2
pkgdesc="Common dependency management for various Trail of Bits C++ codebases"
arch=('x86_64')
url="https://github.com/trailofbits/cxx-common"
license=('Apache')
-depends=('openssl' 'ncurses' 'libxml2' 'zlib')
-makedepends=('cmake' 'python' 'llvm=11.0.0' 'clang=11.0.0' 'ninja')
+depends=('openssl' 'ncurses' 'zlib')
+makedepends=()
checkdepends=()
-source=("https://github.com/trailofbits/cxx-common/archive/v${pkgver}.tar.gz")
-sha256sums=('1f7c3de3fa491cfba52abd4ae5fe5cc00112309239737b89ecc8c00a9b6cb2c2')
-
-build() {
- export TRAILOFBITS_LIBRARIES="$srcdir/libraries"
- cd "$srcdir/$pkgname-$pkgver"
- ./pkgman.py \
- --llvm_version=1100 --c_compiler=clang --cxx_compiler=clang++ \
- --repository_path="${TRAILOFBITS_LIBRARIES}" \
- --packages=cmake,z3,llvm,google,xed,capnproto
-}
+options=('staticlibs' '!strip')
+source=("https://github.com/trailofbits/cxx-common/releases/download/v${pkgver}/libraries-llvm1100-ubuntu20.04-amd64.tar.xz")
+sha256sums=('7a680ea1185dfb83bc8a2c3bdb7930e5c1dfc7d78e3af16da65ca525e82ade39')
package() {
install -dm 755 "$pkgdir/opt/$pkgname"
cp -r "$srcdir/libraries" "$pkgdir/opt/$pkgname/"
- find "$pkgdir/opt/$pkgname/" -type f -exec sed -i -e "s|$srcdir|/opt/$pkgname|g" {} +
}
# vim: set sw=4 ts=4 et: