summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..453713b504ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cxxtools-git
+ pkgdesc = A modular, multithreaded, high performance webapplication server for C++
+ pkgver = 2.2.2.8ee2899
+ pkgrel = 1
+ url = http://www.tntnet.org/cxxtools
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = gcc-libs
+ depends = sh
+ provides = cxxtools
+ conflicts = cxxtools
+ source = cxxtools-git::git+https://github.com/maekitalo/cxxtools.git
+ sha256sums = SKIP
+
+pkgname = cxxtools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72631fa7dfaa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jonas Platte <aur@jonasplatte.de>
+
+pkgname=cxxtools-git
+pkgver=2.2.2.8ee2899
+pkgrel=1
+pkgdesc="A modular, multithreaded, high performance webapplication server for C++"
+arch=('i686' 'x86_64')
+url="http://www.tntnet.org/cxxtools"
+license=('LGPL')
+depends=('gcc-libs' 'sh')
+makedepends=('git')
+provides=('cxxtools')
+conflicts=('cxxtools')
+source=("$pkgname::git+https://github.com/maekitalo/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+# This will very likely break if cxxtools starts using tags. That is intentional,
+# as the --always will be removed then anyway, requiring an update
+pkgver() {
+ cd "$pkgname"
+ echo "2.2.2.$(git describe --always)"
+}
+
+build() {
+ cd "$pkgname"
+
+ autoreconf -i
+ ./configure --enable-silent-rules --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname"
+
+ ./test/alltests
+}
+
+package() {
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir/" install
+}