summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65be2bb5060b..42a6f9e34f0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cylon
pkgdesc = Updates, Maintenance, backup and system checks in a menu driven Bash script
- pkgver = 3.0
- pkgrel = 1
+ pkgver = 3.1
+ pkgrel = 2
url = https://github.com/gavinlyonsrepo/cylon
arch = any
license = GPL
@@ -9,6 +9,7 @@ pkgbase = cylon
optdepends = gdrive: AUR package for google drive backup
optdepends = lostfiles: AUR package for finding lost files
optdepends = pacaur: AUR helper
+ optdepends = arch-audit: AUR package collect CVE data
optdepends = rmlint: Finds lint and other unwanted
optdepends = rkhunter: finds root kits malware
optdepends = clamav: used for finding malware
@@ -21,8 +22,9 @@ pkgbase = cylon
optdepends = wavemon: wireless network monitor
optdepends = speedtest-cli: internet bandwidth
optdepends = lynis: system audit tool
- source = https://github.com/gavinlyonsrepo/cylon/archive/3.0.tar.gz
- md5sums = 53233eeb97e9982176e4269ad3a1df2f
+ optdepends = openbsd-netcat: used for checking network
+ source = https://github.com/gavinlyonsrepo/cylon/archive/3.1.tar.gz
+ md5sums = c41fb7841fa5c03601f2aa7b8a551d5f
pkgname = cylon
diff --git a/PKGBUILD b/PKGBUILD
index b7ca8f0fdb53..06460b0eb8af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: gavin lyons <glyons66@hotmail.com>
# https://github.com/gavinlyonsrepo/cylon
pkgname=cylon
-pkgver=3.0
-pkgrel=1
+pkgver=3.1
+pkgrel=2
pkgdesc="Updates, Maintenance, backup and system checks in a menu driven Bash script"
arch=('any')
url="https://github.com/gavinlyonsrepo/cylon"
@@ -12,6 +12,7 @@ optdepends=(
'gdrive: AUR package for google drive backup'
'lostfiles: AUR package for finding lost files'
'pacaur: AUR helper'
+ 'arch-audit: AUR package collect CVE data'
'rmlint: Finds lint and other unwanted'
'rkhunter: finds root kits malware'
'clamav: used for finding malware'
@@ -24,10 +25,10 @@ optdepends=(
'wavemon: wireless network monitor'
'speedtest-cli: internet bandwidth'
'lynis: system audit tool'
-
+ 'openbsd-netcat: used for checking network'
)
source=("https://github.com/gavinlyonsrepo/cylon/archive/$pkgver.tar.gz")
-md5sums=('53233eeb97e9982176e4269ad3a1df2f')
+md5sums=('c41fb7841fa5c03601f2aa7b8a551d5f')
package() {
cd "$srcdir/${pkgname}-${pkgver}"