summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 24 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1cb1694489f..07b4cee85398 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,17 @@
pkgbase = cylon
- pkgdesc = Maintenance , backups and system checks in a menu driven Bash script
- pkgver = 2.0
- pkgrel = 8
+ pkgdesc = Maintenance , backup and system checks in a menu driven Bash script
+ pkgver = 2.1
+ pkgrel = 9
url = https://github.com/gavinlyonsrepo/cylon
arch = any
license = GPL
+ optdepends = cower: AUR package for AUR work
+ optdepends = gdrive: AUR package for google drive backup
+ optdepends = lostfiles: AUR package for finding lost files
+ optdepends = rmlint: Finds lint and other unwanted
+ optdepends = rkhunter: finds root kits malware
+ optdepends = clamav: used for finding malware
+ optdepends = bleachbit: used for system clean
source = git://github.com/gavinlyonsrepo/cylon.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 20c8d25fed05..7014330b5b86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,22 @@
# Maintainer: gavin lyons <glyons66@hotmail.com>
# https://github.com/gavinlyonsrepo/cylon
pkgname=cylon
-pkgver=2.0
-pkgrel=8
+pkgver=2.1
+pkgrel=9
epoch=
pkgdesc="Maintenance , backup and system checks in a menu driven Bash script"
arch=('any')
url="https://github.com/gavinlyonsrepo/cylon"
license=('GPL')
+optdepends=(
+ 'cower: AUR package for AUR work'
+ 'gdrive: AUR package for google drive backup'
+ 'lostfiles: AUR package for finding lost files'
+ 'rmlint: Finds lint and other unwanted'
+ 'rkhunter: finds root kits malware'
+ 'clamav: used for finding malware'
+ 'bleachbit: used for system clean'
+)
source=("git://github.com/gavinlyonsrepo/${pkgname%-git}.git")
md5sums=('SKIP')
@@ -16,5 +25,7 @@ package() {
install -D -m755 Cylon.sh "$pkgdir"/usr/bin/"${pkgname%-git}"
mkdir -p "$HOME/.config/cylon/"
install -D -m644 Readme.md "$HOME"/.config/cylon/cylonReadme.md
+ install -D -m644 License.md "$pkgdir/usr/share/licenses/${pkgname%-git}/License.md"
}
-md5sums=('SKIP')
+
+