summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD34
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f25f033f8b0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = cynthiune.app
+ pkgdesc = Romantic and extensible music player for GNUstep and Mac OS X
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://gap.nongnu.org/cynthiune/index.html
+ arch = i686
+ arch = x86_64
+ groups = gnustep-apps
+ license = GPL
+ makedepends = gcc-objc
+ makedepends = gnustep-make
+ depends = gnustep-base
+ depends = gnustep-gui
+ depends = gnustep-back
+ depends = libid3tag
+ depends = libmad
+ depends = libvorbis
+ depends = libogg
+ depends = libmpcdec
+ depends = esound
+ source = http://savannah.nongnu.org/download/gap/Cynthiune-1.0.0.tar.gz
+ sha256sums = 3cc5228c8cdb66256bbcec4b317bbd3853397f09ec9b7378a7f65140eff5bcaf
+
+pkgname = cynthiune.app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..234f51cb1b7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+_pkgname=Cynthiune
+pkgname=cynthiune.app
+pkgrel=1
+pkgver=1.0.0
+pkgdesc='Romantic and extensible music player for GNUstep and Mac OS X'
+arch=('i686' 'x86_64')
+url='http://gap.nongnu.org/cynthiune/index.html'
+license=('GPL')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back' 'libid3tag' 'libmad' 'libvorbis' 'libogg' 'libmpcdec' 'esound')
+#optdepends=('libid3tag' 'libmad' 'libvorbis' 'libogg' 'libmpcdec' 'esound')
+makedepends=('gcc-objc' 'gnustep-make')
+source=("http://savannah.nongnu.org/download/gap/Cynthiune-1.0.0.tar.gz")
+sha256sums=('3cc5228c8cdb66256bbcec4b317bbd3853397f09ec9b7378a7f65140eff5bcaf')
+
+build() {
+ cd $_pkgname-$pkgver
+
+ # Leave out avifile library until available
+ if test "$pkg-config --exists avifile" != 0; then
+ sed -i '70,73{s/^.*//}' GNUmakefile
+ fi
+
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+} \ No newline at end of file