summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD21
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de6314e846b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = cypher-shell
+ pkgdesc = A command line shell where you can execute Cypher against an instance of Neo4j
+ pkgver = 1.1.10
+ pkgrel = 1
+ url = https://github.com/neo4j/cypher-shell
+ arch = any
+ license = GPL3
+ depends = java-runtime>=8
+ source = cypher-shell-1.1.10.zip::https://github.com/neo4j/cypher-shell/releases/download/1.1.10/cypher-shell.zip
+ md5sums = c9c04b2744e6429cb21a17c0cc279047
+
+pkgname = cypher-shell
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..400fbff6d813
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+*.crt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6eec41182ef1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Zhanibek Adilbekov <zhanibek.adilbekov@pm.me>
+pkgname=cypher-shell
+pkgver=1.1.10
+pkgrel=1
+pkgdesc="A command line shell where you can execute Cypher against an instance of Neo4j"
+arch=('any')
+url="https://github.com/neo4j/cypher-shell"
+license=('GPL3')
+depends=('java-runtime>=8')
+source=(
+ "$pkgname-$pkgver.zip::https://github.com/neo4j/cypher-shell/releases/download/$pkgver/cypher-shell.zip")
+md5sums=('c9c04b2744e6429cb21a17c0cc279047')
+
+package() {
+ mkdir -p $pkgdir/usr/share/$pkgname
+ install -Dm755 $srcdir/$pkgname/cypher-shell $pkgdir/usr/share/$pkgname/cypher-shell
+ install -Dm755 $srcdir/$pkgname/cypher-shell.bat $pkgdir/usr/share/$pkgname/cypher-shell.bat
+ install -Dm644 $srcdir/$pkgname/cypher-shell.jar $pkgdir/usr/share/$pkgname/cypher-shell.jar
+ install -dm755 $pkgdir/usr/bin
+ ln -sf /usr/share/$pkgname/cypher-shell $pkgdir/usr/bin/cypher-shell
+}