summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f66239c4f1d..1cd9094195df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Dec 11 18:16:01 UTC 2015
pkgbase = czmqpp-git
pkgdesc = C++ wrapper for czmq
pkgver = 20150212
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/zeromq/czmqpp
arch = i686
arch = x86_64
license = LGPL3
makedepends = autoconf
+ makedepends = czmq-git
makedepends = gcc
makedepends = git
makedepends = make
makedepends = pkg-config
- depends = czmq-git
- depends = zeromq
+ makedepends = zeromq
provides = czmqpp
conflicts = czmqpp
source = git+https://github.com/zeromq/czmqpp
diff --git a/PKGBUILD b/PKGBUILD
index 8e3b90201524..971c9dc9b9c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,16 @@
pkgname=czmqpp-git
pkgver=20150212
-pkgrel=1
+pkgrel=2
pkgdesc="C++ wrapper for czmq"
arch=('i686' 'x86_64')
-depends=('czmq-git' 'zeromq')
-makedepends=('autoconf' 'gcc' 'git' 'make' 'pkg-config')
+makedepends=('autoconf'
+ 'czmq-git'
+ 'gcc'
+ 'git'
+ 'make'
+ 'pkg-config'
+ 'zeromq')
url="https://github.com/zeromq/czmqpp"
license=('LGPL3')
source=(git+https://github.com/zeromq/czmqpp)
@@ -23,7 +28,7 @@ pkgver() {
build() {
cd ${pkgname%-git}
- msg 'Building...'
+ msg2 'Building...'
./autogen.sh
./configure \
--prefix=/usr \
@@ -39,9 +44,9 @@ build() {
package() {
cd ${pkgname%-git}
- msg 'Installing...'
+ msg2 'Installing...'
make DESTDIR="$pkgdir" install
- msg 'Cleaning up pkgdir...'
+ msg2 'Cleaning up pkgdir...'
find "$pkgdir" -type d -name .git -exec rm -r '{}' +
}