summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3218fdc5f097..f2f03a31deeb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = dae
pkgdesc = A Linux lightweight and high-performance transparent proxy solution based on eBPF.
pkgver = 0.1.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/daeuniverse/dae
arch = x86_64
license = AGPL
makedepends = clang
makedepends = llvm
makedepends = go
- source = https://github.com/daeuniverse/dae/releases/download/v0.1.6/dae-full-src.zip
- sha256sums = 226aa5a8538ebcc009391fbeb7cad56ec60207a64bb43c8cbd89a60412c79b1a
+ source = dae-0.1.6.zip::https://github.com/daeuniverse/dae/releases/download/v0.1.6/dae-full-src.zip
+ sha256sums = fa1b06c73ddbb4b6aebc387c30b1f026d155fc273d4058d95ebc75188fde5037
pkgname = dae
depends = glibc
diff --git a/PKGBUILD b/PKGBUILD
index d8962045a5cd..7d4623694003 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,16 @@ pkgname=(
$_pkgname-geosite-v2raycompat
)
pkgver=0.1.6
-pkgrel=1
+pkgrel=2
pkgdesc="A Linux lightweight and high-performance transparent proxy solution based on eBPF."
arch=(x86_64)
url="https://github.com/daeuniverse/dae"
license=('AGPL')
makedepends=(clang llvm go)
source=(
- "https://github.com/daeuniverse/dae/releases/download/v$pkgver/dae-full-src.zip"
+ "$_pkgname-$pkgver.zip::https://github.com/daeuniverse/dae/releases/download/v$pkgver/dae-full-src.zip"
)
-sha256sums=('226aa5a8538ebcc009391fbeb7cad56ec60207a64bb43c8cbd89a60412c79b1a')
+sha256sums=('fa1b06c73ddbb4b6aebc387c30b1f026d155fc273d4058d95ebc75188fde5037')
build() {
export GOFLAGS="-buildmode=pie -trimpath -modcacherw"