summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD52
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20849a521ecb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dafny-git
+ pkgdesc = Dafny is a verification-aware programming language
+ pkgver = v2.2.0.r19.g45af975d
+ pkgrel = 1
+ url = https://github.com/Microsoft/dafny.git
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = wget
+ depends = gcc-libs
+ provides = dafny
+ source = dafny-git::git+https://github.com/Microsoft/dafny.git
+ md5sums = SKIP
+
+pkgname = dafny-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..224c892b7cb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: crave <crave@infinity>
+
+pkgname=dafny-git
+pkgver=v2.2.0.r19.g45af975d
+pkgrel=1
+pkgdesc="Dafny is a verification-aware programming language"
+arch=('i686' 'x86_64')
+url="https://github.com/Microsoft/dafny.git"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('git' 'wget')
+provides=('dafny')
+source=("$pkgname"::"git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/z3-//;s/-/.r/;s/-/./'
+}
+
+build() {
+ if [ ! -d "boogie" ]; then
+ git clone https://github.com/boogie-org/boogie.git
+ else
+ (cd boogie && git pull)
+ fi
+ [ -f nuget.exe ] || wget https://nuget.org/nuget.exe
+
+ mono ./nuget.exe restore boogie/Source/Boogie.sln
+ msbuild boogie/Source/Boogie.sln
+
+ mono ./nuget.exe restore dafny-git/Source/Dafny.sln
+ msbuild dafny-git/Source/Dafny.sln
+
+ #mono ./nuget.exe restore dafny-git/Source/DafnyExtension.sln
+ #msbuild dafny-git/Source/DafnyExtension.sln
+}
+
+package() {
+ cd ${pkgname}/Binaries
+
+ # Creating directories
+ install -dm755 $pkgdir/opt/dafny
+ install -dm755 $pkgdir/usr/bin
+
+ # Copy dependencies
+ cp -r * "${pkgdir}"/opt/dafny/
+ ln -s /opt/dafny/dafny "${pkgdir}"/usr/bin/dafny
+ mkdir -p "${pkgdir}/opt/dafny/z3/bin"
+ ln -s /usr/bin/z3 "${pkgdir}/opt/dafny/z3/bin/z3"
+}
+