summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
3 files changed, 57 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..89a78fcb1769
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = danmaku2ass-git
+ pkgdesc = Convert comments from Niconico/AcFun/bilibili to ASS format
+ pkgver = 20140615
+ pkgrel = 1
+ url = https://github.com/m13253/danmaku2ass
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python>=3
+ provides = danmaku2ass
+ conflicts = danmaku2ass
+ source = danmaku2ass::git://github.com/m13253/danmaku2ass.git
+
+pkgname = danmaku2ass-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5efacb6025c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = danmaku2ass-git
+ pkgdesc = Convert comments from Niconico/AcFun/bilibili to ASS format
+ pkgver = 20140615
+ pkgrel = 1
+ url = https://github.com/m13253/danmaku2ass
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python>=3
+ provides = danmaku2ass
+ conflicts = danmaku2ass
+ source = danmaku2ass::git://github.com/m13253/danmaku2ass.git
+ md5sums = SKIP
+
+pkgname = danmaku2ass-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5aeeca7ebfea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# PKGBUILD file for Arch Linux packaging
+# Contributor: Star Brilliant <echo bTEzMjUzQGhvdG1haWwuY29tCg== | base64 -d>
+
+pkgname=danmaku2ass-git
+pkgver=20140615
+pkgrel=1
+pkgdesc="Convert comments from Niconico/AcFun/bilibili to ASS format"
+arch=('any')
+url="https://github.com/m13253/danmaku2ass"
+license=('GPL3')
+depends=('python>=3')
+makedepends=('git')
+provides=('danmaku2ass')
+conflicts=('danmaku2ass')
+source=('danmaku2ass::git://github.com/m13253/danmaku2ass.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/danmaku2ass"
+ git log -1 --format="%cd" --date=short | tr -d -
+}
+
+package() {
+ cd "$srcdir/danmaku2ass"
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+}