summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index faa85283db64..5a86d8e1947d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jan 15 00:38:05 UTC 2016
+# Sun Feb 28 15:44:56 UTC 2016
pkgbase = dar
pkgdesc = A full featured command-line backup tool, short for Disk ARchive
pkgver = 2.5.3
- pkgrel = 1
+ pkgrel = 2
url = http://dar.linux.free.fr/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index de2a47aa5403..2a499ee3475f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Maintainer: N. I. - izmntuk
pkgname=dar
pkgver=2.5.3
-pkgrel=1
+pkgrel=2
pkgdesc='A full featured command-line backup tool, short for Disk ARchive'
arch=('i686' 'x86_64')
url='http://dar.linux.free.fr/'
@@ -19,7 +19,12 @@ options=('!libtool')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
## --enable-threadar: EXPERIMENTAL multithread support
- ./configure --prefix=/usr --sysconfdir=/etc --disable-dar-static --disable-static --disable-upx --disable-build-html
+ if [[ "${CARCH}" == x86_64 ]];then
+ EXTRA_OPTIONS="--enable-mode=64"
+ elif [[ "${CARCH}" == i686 ]];then
+ EXTRA_OPTIONS="--enable-mode=32"
+ fi
+ ./configure --prefix=/usr --sysconfdir=/etc --disable-dar-static --disable-static --disable-upx --disable-build-html ${EXTRA_OPTIONS}
make
}